cancel
Showing results for 
Search instead for 
Did you mean: 

Update error : Your requirements could not be resolved to an installable set of packages.

Update error : Your requirements could not be resolved to an installable set of packages.

I'm trying to update from 2.1.x to Magento 2.x but I hangs with the following message

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - adwise/language-nl_nl 1.2.2 requires magento/framework ^100.0.0 -> satisfiable by magento/framework[100.1.9, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.2.0-rc20, 100.0.18, 100.0.19, 100.1.10, 100.1.11, 100.0.20, 100.1.12].
    - adwise/language-nl_nl 1.2.2 requires magento/framework ^100.0.0 -> satisfiable by magento/framework[100.1.9, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.2.0-rc20, 100.0.18, 100.0.19, 100.1.10, 100.1.11, 100.0.20, 100.1.12].
    - adwise/language-nl_nl 1.2.0 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
    - Can only install one of: magento/framework[101.0.0, 100.1.9].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc1].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc2].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc3].
    - Can only install one of: magento/framework[101.0.0, 100.1.0].
    - Can only install one of: magento/framework[101.0.0, 100.1.1].
    - Can only install one of: magento/framework[101.0.0, 100.1.2].
    - Can only install one of: magento/framework[101.0.0, 100.1.3].
    - Can only install one of: magento/framework[101.0.0, 100.1.4].
    - Can only install one of: magento/framework[101.0.0, 100.1.5].
    - Can only install one of: magento/framework[101.0.0, 100.1.6].
    - Can only install one of: magento/framework[101.0.0, 100.1.7].
    - Can only install one of: magento/framework[101.0.0, 100.1.8].
    - Can only install one of: magento/framework[101.0.0, 100.1.9].
    - Can only install one of: magento/framework[100.1.10, 101.0.0].
    - Can only install one of: magento/framework[100.1.11, 101.0.0].
    - Can only install one of: magento/framework[100.1.12, 101.0.0].
    - Can only install one of: magento/framework[101.0.0, 100.0.2].
    - Can only install one of: magento/framework[101.0.0, 100.0.3].
    - Can only install one of: magento/framework[101.0.0, 100.0.4].
    - Can only install one of: magento/framework[101.0.0, 100.0.5].
    - Can only install one of: magento/framework[101.0.0, 100.0.6].
    - Can only install one of: magento/framework[101.0.0, 100.0.7].
    - Can only install one of: magento/framework[101.0.0, 100.0.8].
    - Can only install one of: magento/framework[101.0.0, 100.0.9].
    - Can only install one of: magento/framework[101.0.0, 100.0.10].
    - Can only install one of: magento/framework[101.0.0, 100.0.11].
    - Can only install one of: magento/framework[101.0.0, 100.0.12].
    - Can only install one of: magento/framework[101.0.0, 100.0.13].
    - Can only install one of: magento/framework[101.0.0, 100.0.14].
    - Can only install one of: magento/framework[101.0.0, 100.0.15].
    - Can only install one of: magento/framework[101.0.0, 100.0.16].
    - Can only install one of: magento/framework[101.0.0, 100.0.17].
    - Can only install one of: magento/framework[101.0.0, 100.2.0-rc20].
    - Can only install one of: magento/framework[101.0.0, 100.0.18].
    - Can only install one of: magento/framework[100.0.19, 101.0.0].
    - Can only install one of: magento/framework[100.0.20, 101.0.0].
    - magento/product-community-edition 2.2.0 requires magento/framework 101.0.0 -> satisfiable by magento/framework[101.0.0].
    - Installation request for magento/product-community-edition 2.2.0 -> satisfiable by magento/product-community-edition[2.2.0].
    - Installation request for adwise/language-nl_nl ^1.2 -> satisfiable by adwise/language-nl_nl[1.2.0, 1.2.2].

Can somebody explain me what to do?
I guess it is something with the adwise language module but this I don't really need.

 

----------------------------------------------------------------------------
PdM internetdiensten voor webwinkels & websites.
1 REPLY

Re: Update error : Your requirements could not be resolved to an installable set of packages.

Hi @qwyrp,

 

Can you check the NL language package/module dependencies?

It seems that module is currently compatible with Magento 2.1.x. Maybe there is a dependency with a Magento module indicated as 100.0.*

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"