cancel
Showing results for 
Search instead for 
Did you mean: 

Update from Magento 2.2.5-dev to latest

Highlighted

Update from Magento 2.2.5-dev to latest

Hello there,

 

a client popped up with a request of update of his Magento version - after a check I found the version as 2.2.5-dev Community Edition - the command line update: https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html not works - it ends with "Your requirements could not be resolved to an installable set of packages."


Could be that the first installation was done by cloning the GIT repository? But in the project I am not find any reference to GIT ( for example: .git, .gitignore ).

 

Any tips to how can I sort this out?

 

Thank you in advance for any advice.

 

Cheers,

Vince

8 REPLIES 8
Highlighted

Re: Update from Magento 2.2.5-dev to latest

Hi @vincesta 

Make sure that you PHP version and required php extensions is compatible with Magento latest version. GIT installation will does not effect on this.

https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

I hope it will help you!

Highlighted

Re: Update from Magento 2.2.5-dev to latest

Hi @Vimal Kumar thank you for your reply.

 

Ok, let me try to update php version - hopefully the problem is this.

 

I'll keep you posted.

 

Thanks,

Vince

Highlighted

Re: Update from Magento 2.2.5-dev to latest

Hi @Vimal Kumar after update the php version to 7.3 and update the composer.phar, I updated the required library versions in composer.json and changed: "name": "magento/magento2ce",  with "name": "magento/project-community-edition"

It starts to update the components but at the end fails with this error: 

 [InvalidArgumentException]
  Package is not installed: magento/project-community-edition-2.3.5

What went wrong?

 

Thank you for your help! 

Highlighted

Re: Update from Magento 2.2.5-dev to latest

Hi @vincesta 

Follow the below Magento document,

 

https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html

I hope it will help you!

Highlighted

Re: Update from Magento 2.2.5-dev to latest

Hi @Vimal Kumar thank you for your help,

but the magento document you linked, not worked for me.

 

It can be an issue with composer.json content? 

 

Thanks,

Vince

Highlighted

Re: Update from Magento 2.2.5-dev to latest

Hi @vincesta 

https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html

The link is working for me..

please check once again.

Highlighted

Re: Update from Magento 2.2.5-dev to latest

Hi @Vimal Kumar,

 

after various edit to composer.json it started to update and installing the new packages, but ended with this error:

 

In LibraryInstaller.php line 134:
Package is not installed: magento/magento2-base-2.3.5.0

On frontend I see:

Autoload error

Vendor autoload is not found. Please run 'composer install' under application root directory.

 

I try to run "composer install" but I got: 

 

Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package laminas/laminas-captcha 2.8.0 exists as laminas/laminas-captcha[2.9.0] but these are rejected by your constraint.
Problem 2
- The requested package laminas/laminas-code 3.1.0 exists as laminas/laminas-code[3.3.2] but these are rejected by your constraint.
Problem 3
- The requested package laminas/laminas-console 2.7.0 exists as laminas/laminas-console[2.8.0] but these are rejected by your constraint.
Problem 4
- The requested package laminas/laminas-db 2.11.0 exists as laminas/laminas-db[2.11.3] but these are rejected by your constraint.
Problem 5
- The requested package laminas/laminas-diactoros 1.8.7 exists as laminas/laminas-diactoros[1.8.7p2] but these are rejected by your constraint.
Problem 6
- The requested package laminas/laminas-eventmanager 2.6.4 exists as laminas/laminas-eventmanager[3.2.1] but these are rejected by your constraint.
Problem 7
- The requested package laminas/laminas-filter 2.9.2 exists as laminas/laminas-filter[2.9.4] but these are rejected by your constraint.
Problem 8
- The requested package laminas/laminas-form 2.13.0 exists as laminas/laminas-form[2.14.5] but these are rejected by your constraint.
Problem 9
- The requested package laminas/laminas-http 2.8.4 exists as laminas/laminas-http[2.11.2] but these are rejected by your constraint.
Problem 10
- The requested package laminas/laminas-hydrator 1.1.0 exists as laminas/laminas-hydrator[2.4.2] but these are rejected by your constraint.
Problem 11
- The requested package laminas/laminas-i18n 2.10.1 exists as laminas/laminas-i18n[2.10.3] but these are rejected by your constraint.
Problem 12
- The requested package laminas/laminas-session 2.8.7 exists as laminas/laminas-session[2.9.3] but these are rejected by your constraint.
Problem 13
- The requested package laminas/laminas-stdlib 2.7.7 exists as laminas/laminas-stdlib[3.2.1] but these are rejected by your constraint.
Problem 14
- The requested package laminas/laminas-validator 2.11.1 exists as laminas/laminas-validator[2.13.4] but these are rejected by your constraint.

 

Any suggestion?

 

Thank you for your help!

Highlighted

Re: Update from Magento 2.2.5-dev to latest

is it solve?