cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade 2.3.3 to 2.4.2

Upgrade 2.3.3 to 2.4.2

I'm trying to upgrade from 2.3.3 to 2.4.2.  I've tried everything under the sun to get this to work.  I've been working on this for days and have started over numerous times.  I keep running into php version errors.  I've trying running the upgrade before updating php, after updating php, etc.  Nothing is working.

 

I run the following:

composer require magento/product-community-edition 2.4.2 --no-update

composer update

 

That returns errors.  If i attempt to fix those errors, it produces more errors.

 

Output:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- This package requires php ~7.1.3||~7.2.0||~7.3.0 but your PHP version (7.4.22) does not satisfy that requirement.
Problem 2
- Installation request for magento/product-community-edition 2.4.2 -> satisfiable by magento/product-community-edition[2.4.2].
- magento/product-community-edition 2.4.2 requires colinmollenhour/cache-backend-redis 1.11.0 -> satisfiable by colinmollenhour/cache-backend-redis[1.11.0] but these conflict with your requirements or minimum-stability.
Problem 3
- magento/composer 1.5.1 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.4.22) does not satisfy that requirement.
- magento/composer 1.5.0 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.4.22) does not satisfy that requirement.
- magento/composer 1.5.1 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.4.22) does not satisfy that requirement.
- magento/composer 1.5.1 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.4.22) does not satisfy that requirement.
- Installation request for magento/composer ~1.5.0 -> satisfiable by magento/composer[1.5.1, 1.5.0].

 

7 REPLIES 7

Re: Upgrade 2.3.3 to 2.4.2

Hello @mattisjd ,

 

Did you try this command with php7.3 ?

it's throwing error for PHP version. First install a fresh installation of Magento 2.4.2 so you'll know the requirements for Magento 2.4.2 and the compatibility with server.

then try to migrate the Magento version.

 

Let me know if face any error again.

Best Regards

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !

Re: Upgrade 2.3.3 to 2.4.2

Correct me if I'm wrong, but per the documenation, PHP 7.4 is required for Magento 2.4.2

 

https://devdocs.magento.com/guides/v2.4/install-gde/system-requirements.html

 

I have tried 7.3, and get an entirely different set of errors.  I will have to reload php 7.3 and run the composer update and try that again.  What does installing a clean version of 2.4.2 on this server do for me?  I still have to be able to run the update to migrate from 2.3.3 to 2.4.2, do I not?

 

I will run the update with 7.3 and post back the errors i receive with that version. 

 

Thanks for the help.

 

Re: Upgrade 2.3.3 to 2.4.2

With PHP 7.3 installed:

 

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/product-community-edition 2.4.2 -> satisfiable by magento/product-community-edition[2.4.2].
- magento/product-community-edition 2.4.2 requires colinmollenhour/cache-backend-redis 1.11.0 -> satisfiable by colinmollenhour/cache-backend-redis[1.11.0] but these conflict with your requirements or minimum-stability.

 

Thanks for looking at this for me.

Re: Upgrade 2.3.3 to 2.4.2

Still have this same issue, and I can't figure out a way around it...anyone?

 

Thanks!

Re: Upgrade 2.3.3 to 2.4.2


@mattisjd wrote:

Correct me if I'm wrong, but per the documenation, PHP 7.4 is required for Magento 2.4.2

 

https://devdocs.magento.com/guides/v2.4/install-gde/system-requirements.html

 

I have tried 7.3, and get an entirely different set of errors.  I will have to reload php 7.3 and run and stuck to screen to the composer update and try that again.  What does installing a clean version of 2.4.2 on this server do for me?  I still have to be able to run the update to migrate from 2.3.3 to 2.4.2, do I not?

 

I will run the update with 7.3 and post back the errors i receive with that version. 

 

Thanks for the help.

 


is this link is beneficial as i see this is not working for me as i also face same error from last 2 days.

Re: Upgrade 2.3.3 to 2.4.2

I now understand why Magento has such a bad rap.  This is the biggest hodge-podge of crap I've ever dealt with.  I have never seen an upgrade process so convoluted in my life, and I've seen a lot of bad software written.

 

I'm now on week 2 of this, and still nowhere closer to being migrated to 2.4.2.

 

I have PHP 7.4.22, Elasticsearch 7.9, Mariadb 10.4, ubuntu 18.04.

 

I'm getting the following error.

 

Problem 1
- Installation request for magento/magento2ce 2.4.2 -> satisfiable by magento/magento2ce[2.4.2].
- magento/product-community-edition 2.4.2 requires magento/magento2-base 2.4.2 -> satisfiable by magento/magento2-base[2.4.2].
- don't install magento/magento2-base 2.4.2|remove magento/magento2ce 2.4.2
- Installation request for magento/product-community-edition 2.4.2 -> satisfiable by magento/product-community-edition[2.4.2]

Re: Upgrade 2.3.3 to 2.4.2

For anyone that was following this thread.  I gave up on all of these bogus errors.  I ended up installing a clean version of 2.3.3-p1 on my server.  I then copied the media directory over and restored the database.  I was able to get it working after a few minor tweaks.  I then upgraded using composer to 2.4.0.  There were a few small issues along the way, but I got it installed.