cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

SOLVED

Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

Hello.

Magento 2.2.0 GA officially announce today and placed on official download for public.

I just wanna know, how to upgrade or migrate from Magento 2.1.9 to 2.2.0 ? Is it like else such as from 2.1.8 to 2.1.9 ? or should use a tool migrate?

 

Thank you.

Jurpro.

7 REPLIES

Re: Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

Open your root composer.json file

Replace with below content,

"version": "2.1.9" replace with "version": "2.2.0"
"magento/product-community-edition": "2.1.9" replace with "magento/product-community-edition": "2.2.0"

 

run command from magento 2 root,

composer update

After successfully completed upgradation,

run 

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy

if issue solved, Click kudos/Accept as solutions.

If Issue Solved, Click Kudos/Accept As solutions.

Re: Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

Hello.

 

It seems we can only run setup:upgrade as well as we update from 2.1.8 to 2.1.9

And my Magento 2.2.0 now run perfectly.

Thanks.

I will check any new facility or module etc on admin panel 2.2.0

Smiley Happy

Re: Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

Will it work with sample data as well ? How could I upgrade to version 2.2.0 with and without sample data ?


Rakesh Jesadiya wrote:

Open your root composer.json file

Replace with below content,

"version": "2.1.9" replace with "version": "2.2.0"
"magento/product-community-edition": "2.1.9" replace with "magento/product-community-edition": "2.2.0"

 

run command from magento 2 root,

composer update

After successfully completed upgradation,

run 

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy

if issue solved, Click kudos/Accept as solutions.


 

Re: Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

composer.json after upgrade from 2.1.9 to 2.2.0

 

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.1.9",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/product-community-edition": "2.2.0",
        "composer/composer": "@alpha",
        "magento/module-bundle-sample-data": "100.2.*",
        "magento/module-theme-sample-data": "100.2.*",
        "magento/module-catalog-sample-data": "100.2.*",
        "magento/module-cms-sample-data": "100.2.*",
        "magento/module-widget-sample-data": "100.2.*",
        "magento/module-tax-sample-data": "100.2.*",
        "magento/module-customer-sample-data": "100.2.*",
        "magento/module-catalog-rule-sample-data": "100.2.*",
        "magento/module-sales-rule-sample-data": "100.2.*",
        "magento/module-sales-sample-data": "100.2.*",
        "magento/module-grouped-product-sample-data": "100.2.*",
        "magento/module-downloadable-sample-data": "100.2.*",
        "magento/module-msrp-sample-data": "100.2.*",
        "magento/module-configurable-sample-data": "100.2.*",
        "magento/module-product-links-sample-data": "100.2.*",
        "magento/module-wishlist-sample-data": "100.2.*",
        "magento/module-review-sample-data": "100.2.*",
        "magento/module-swatches-sample-data": "100.2.*",
        "magento/sample-data-media": "100.2.*",
        "magento/module-offline-shipping-sample-data": "100.2.*"
    },
    "require-dev": {
        "phpunit/phpunit": "4.1.0",
        "squizlabs/php_codesniffer": "1.5.3",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.4.0",
        "fabpot/php-cs-fixer": "~1.2",
        "lusitanian/oauth": "~0.3 <=0.7.0",
        "sebastian/phpcpd": "2.0.0"
    },
    "config": {
        "use-include-path": true
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": "app/code/"
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "alpha",
    "prefer-stable": true,
    "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    ],
    "extra": {
        "magento-force": "override"
    }
}

composer.json after fresh installation of 2.2.0

 

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.2.0",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/product-community-edition": "2.2.0",
        "composer/composer": "@alpha",
        "magento/module-bundle-sample-data": "100.2.*",
        "magento/module-catalog-sample-data": "100.2.*",
        "magento/module-customer-sample-data": "100.2.*",
        "magento/module-theme-sample-data": "100.2.*",
        "magento/module-widget-sample-data": "100.2.*",
        "magento/module-cms-sample-data": "100.2.*",
        "magento/module-review-sample-data": "100.2.*",
        "magento/module-tax-sample-data": "100.2.*",
        "magento/module-msrp-sample-data": "100.2.*",
        "magento/module-sales-sample-data": "100.2.*",
        "magento/module-catalog-rule-sample-data": "100.2.*",
        "magento/module-configurable-sample-data": "100.2.*",
        "magento/module-product-links-sample-data": "100.2.*",
        "magento/module-wishlist-sample-data": "100.2.*",
        "magento/module-sales-rule-sample-data": "100.2.*",
        "magento/module-downloadable-sample-data": "100.2.*",
        "magento/module-grouped-product-sample-data": "100.2.*",
        "magento/module-swatches-sample-data": "100.2.*",
        "magento/sample-data-media": "100.2.*",
        "magento/module-offline-shipping-sample-data": "100.2.*"
    },
    "require-dev": {
        "phpunit/phpunit": "~6.2.0",
        "squizlabs/php_codesniffer": "3.0.1",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.5.0",
        "friendsofphp/php-cs-fixer": "~2.1.1",
        "lusitanian/oauth": "~0.8.10",
        "sebastian/phpcpd": "2.0.4"
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": [
                "app/code/"
            ]
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ],
        "exclude-from-classmap": [
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "stable",
    "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    ],
    "extra": {
        "magento-force": "override"
    }
}

Does the difference in both composer.json could create issues in future development ?

Is it adivsable to upgrade or install fresh copy in case there is no real data except sample data and/or in case when there is live data available ?
 

Re: Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

The composer.json file after the upgrade will create problems, at least while using tests CLI. I tried the static test check with the next command:

 

php bin/magento dev:tests:run static

 

and crashed with next error:

 

---- /var/www/html/dev/tests/static> /usr/local/bin/php 
/var/www/html/./vendor/phpunit/phpunit/phpunit Warning: require(/var/www/html/vendor/squizlabs/php_codesniffer/autoload.php):
failed to open stream: No such file or directory in
/var/www/html/dev/tests/static/framework/autoload.php on line 11

 

This error was caused by missing the right package version.  The composer.json file needed to have this in it:

 

"squizlabs/php_codesniffer": "3.0.1"

 

This package is included in a fresh install of 2.2 but not in the composer upgrade process.

 

In the end, my solution was to replace the current composer.json after upgrade to 2.2 with the composer.json file of a fresh 2.2 install and added again my required custom packages (please be careful if you have custom compose.json file).

 

Re: Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

I mean, fundamentally, it just doesn't make sense to me. Maybe I need to be educated, but ....

Magento requires a bunch of different modules (some proprietary and some third-party) to become a piece of software, right?

Well, every client you have will require Magento and probably a custom theme repository, and maybe a couple modules, etc.... right?

So just like magento created their own "repo" or "project" with all the dependencies - shouldn't each client create their own project with Magento and the additional depencies? Call me crazy but Composer documentation would consider my website the composer project and magento would be a dependency, among other dependencies..

Does this make sense or am I crazy? The way your documentation sets up projects pretty much "overwrites" the core magento composer.json and lock files and requires the manual commands to be run which is further complicated by private repos requiring credentials that should technically live next to composer.json in auth.json files......wouldn't it make sense not to overwrite the Magento composer.json with the 'composer require' commands so that the file is left intact?

Is this something we can pass on to support management for discussion? I think it would be an enhancement to the way your developers are thinking about "clients," "projects" and "dependencies" in each scenario..

I could be crazy and it's okay for someone to tell me so Smiley Happy

Re: Upgrade / Migrate From Magento 2.1.9 to Magento 2.2.0 GA

Hello. I got this error when I upgrade my live stie to 2.2.0 anyone can help?

 

 

a:4:{i:0;s:3041:"Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory. 
The following modules are outdated:
Magento_Store schema: current version - 2.1.0, required version - 2.0.0
Magento_Store data: current version - 2.1.0, required version - 2.0.0
Magento_Directory schema: current version - 2.0.1, required version - 2.0.0
Magento_Directory data: current version - 2.0.1, required version - 2.0.0
Magento_Eav schema: current version - 2.1.1, required version - 2.0.0
Magento_Eav data: current version - 2.1.1, required version - 2.0.0
Magento_Theme schema: current version - 2.0.2, required version - 2.0.1
Magento_Theme data: current version - 2.0.2, required version - 2.0.1
Magento_Customer schema: current version - 2.0.12, required version - 2.0.9
Magento_Customer data: current version - 2.0.12, required version - 2.0.9
Magento_Indexer schema: current version - 2.1.0, required version - 2.0.0
Magento_Indexer data: current version - 2.1.0, required version - 2.0.0
Magento_Cms schema: current version - 2.0.2, required version - 2.0.1
Magento_Cms data: current version - 2.0.2, required version - 2.0.1
Magento_Catalog schema: current version - 2.2.3, required version - 2.1.4
Magento_Catalog data: current version - 2.2.3, required version - 2.1.4
Magento_Widget schema: current version - 2.0.1, required version - 2.0.0
Magento_Widget data: current version - 2.0.1, required version - 2.0.0
Magento_Quote schema: current version - 2.0.6, required version - 2.0.4
Magento_CheckoutAgreements schema: current version - 2.2.0, required version - 2.0.1
Magento_CurrencySymbol schema: current version - 2.0.1, required version - 2.0.0
Magento_Sales schema: current version - 2.0.7, required version - 2.0.3
Magento_Bundle schema: current version - 2.0.4, required version - 2.0.2
Magento_Downloadable schema: current version - 2.0.2, required version - 2.0.1
Magento_CatalogInventory schema: current version - 2.3.0, required version - 2.0.1
Magento_User schema: current version - 2.0.3, required version - 2.0.1
Magento_CatalogRule schema: current version - 2.1.0, required version - 2.0.1
Magento_ConfigurableProduct schema: current version - 2.2.0, required version - 2.0.0
Magento_SalesRule schema: current version - 2.0.3, required version - 2.0.1
Magento_Paypal schema: current version - 2.0.1, required version - 2.0.0
Magento_OfflineShipping schema: current version - 2.0.1, required version - 2.0.0
Magento_NewRelicReporting schema: current version - 2.0.1, required version - 2.0.0
Magento_Swatches schema: current version - 2.0.3, required version - 2.0.1
Magento_Tax schema: current version - 2.0.2, required version - 2.0.1
Magento_UrlRewrite schema: current version - 2.0.1, required version - 2.0.0
Magento_Braintree schema: current version - 2.0.1, required version - 2.0.0
Magento_Wishlist schema: current version - 2.0.1, required version - 2.0.0
Smartwave_Porto schema: current version - 2.7.0, required version - 2.6.2
Smartwave_Porto data: current version - 2.7.0, required version - 2.6.2";i:1;s:2722:"#0 /home/jurprone/public_html/example.com/vendor/magento/framework/Interception/Chain/Chain.php(67): Magento\Framework\Module\Plugin\DbStatusValidator->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#1 /home/jurprone/public_html/example.com/vendor/magento/framework/Interception/Chain/Chain.php(63): Magento\Framework\Interception\Chain\Chain->invokeNext('Magento\\Framewo...', 'dispatch', Object(Magento\Framework\App\FrontController\Interceptor), Array, 'front-controlle...')
#2 /home/jurprone/public_html/example.com/vendor/magento/module-page-cache/Model/App/FrontController/VarnishPlugin.php(55): Magento\Framework\Interception\Chain\Chain->Magento\Framework\Interception\Chain\{closure}(Object(Magento\Framework\App\Request\Http))
#3 /home/jurprone/public_html/example.com/vendor/magento/framework/Interception/Chain/Chain.php(67): Magento\PageCache\Model\App\FrontController\VarnishPlugin->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#4 /home/jurprone/public_html/example.com/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\Interception\Chain\Chain->invokeNext('Magento\\Framewo...', 'dispatch', Object(Magento\Framework\App\FrontController\Interceptor), Array, 'front-controlle...')
#5 /home/jurprone/public_html/example.com/vendor/magento/module-page-cache/Model/App/FrontController/BuiltinPlugin.php(73): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#6 /home/jurprone/public_html/example.com/vendor/magento/framework/Interception/Interceptor.php(142): Magento\PageCache\Model\App\FrontController\BuiltinPlugin->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#7 /home/jurprone/public_html/example.com/var/generation/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, Array)
#8 /home/jurprone/public_html/example.com/vendor/magento/framework/App/Http.php(135): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#9 /home/jurprone/public_html/example.com/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#10 /home/jurprone/public_html/example.com/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#11 {main}";s:3:"url";s:70:"/manca.html?muisc_genre=223%2C159&p=10&pilihan_versi=61%2C59%2C57%2C56";s:11:"script_name";s:10:"/index.php";}