cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade from 1.9.2.3 to 2.2.3 - upgrade tool access denied error

Upgrade from 1.9.2.3 to 2.2.3 - upgrade tool access denied error

Hi everyone,

 

I'm trying to upgrade from Mag 1.9.2.3 to 2.2.3 using the data migration tool. However when I try and run the tool to migrate settings I'm getting the following error:

 

  [Zend_Db_Adapter_Exception]                                                                         
  SQLSTATE[HY000] [1045] Access denied for user 'user1'@'176.67.164.255' (using password: NO)

 

The settings in config.xml are as follows:

 

    <source>
        <database host="46.23.74.63" name="db_mag" user="user1" pass="password1"/>
    </source>
    <destination>
<database host="176.67.164.255" name="db_mage983" user="user2" pass="password2"/> </destination>

Why does the data migration tool seem to want a user called user1 on the destination db? What am I missing here? Do the usernames have to match on both source and destination db's? Do I need to set password = yes in the data migration tool somehow? If so, how?

 

Thanks in advance.

5 REPLIES

Re: Upgrade from 1.9.2.3 to 2.2.3 - upgrade tool access denied error

For Source Tag with all the data is used from Magento 1 database whereas a Destinataion tag with all attributes data will be from magneto 2 database.

 

For Source you need to add Magento 1 database details.

For Destination you need to add Magento 2 database details.

 

Its not mandatory to keep all the database for M1 and M2 both instance in same database.

If Issue Solved, Click Kudos/Accept As solutions.

Re: Upgrade from 1.9.2.3 to 2.2.3 - upgrade tool access denied error

Hi,

Thanks for replying but I definitely have those settings correct. That's why I'm puzzled by the error message suggesting user1@database2. I've changing those settings around various ways and I still get similar errors. My feeling is that it's permissions based somehow either around mySQL or user/port access.

Thanks

Re: Upgrade from 1.9.2.3 to 2.2.3 - upgrade tool access denied error

It also looks like other people have had similar issues in the past Smiley Sad

 

https://magento.stackexchange.com/questions/145399/magento-2-data-migration-tool-not-connecting-to-r...

 

Re: Upgrade from 1.9.2.3 to 2.2.3 - upgrade tool access denied error

I did a grant all on the db on the remote (source) server. And I can access it from the destination server mysql command line so the destination server can definitely see the source server. Does the user for the remote (source) server need access to the destination server too?

Re: Upgrade from 1.9.2.3 to 2.2.3 - upgrade tool access denied error

I hope your issue get resolved, if not please  make sure that your source and destination database is connected and can communicate as data migration tool checks table from both database while mapping and migrating data.