Trying to upgrade a site to 2.4.4 from 2.4.2 but getting the error below.
Problem 1 - Root composer.json requires magento/product-community-edition 2.4.4 -> satisfiable by magento/product-community-edition[2.4.4]. - magento/product-community-edition 2.4.4 requires php ~7.4.0||~8.1.0 -> your php version (7.3.33) does not satisfy that requirement.
Basically its telling me to use php 7.4.0 or later which I am & if I do php -v its comes back with 7.4.29.
I'm guessing its picking it up as a dependency from a file but I've checked the composer.json & composer. locked files & its not mentioned there.
Does anyone have any ideas where it could be pulling it from?
Magento 2.4.4 only supports 7.4 and higher version
1. Update your composer using the composer update command
2 please check the composer file if the dependency of PHP is not there you can add PHP dependency over there.
Hope this will help you to resolve your issue.
If not feel free to contact us.
If solved? Click KUDOS and accept it as a solution.
Thank you for your reply.
The problem appears to have been with Plesk & composer not using the php version that was set.
I asked Plesk support to have a look & they agreed with me that composer should be using php 7.4 but wasn't.
They asked me to run the update with this command:
composer update --ignore-platform-reqs
which worked & a few days later they released an update which could force composer to use the php version of the domain you were trying to update if that makes sense.