cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade to 2.2.2 prevented and Dotmailer severe issues API endpoint

Upgrade to 2.2.2 prevented and Dotmailer severe issues API endpoint

Hello,

I hope someone else has seen this issue. We DO have an email program to send follow on emails to clients after a set time in our previous 2.1.9 install.

We upgraded using composer to 2.2.1 and all "looked good" (not thoroughly tested).

So we decided since 2.2.2 is better than 2.2.1 - to try that upgrade. On web set up wizard it just stops on update pending. On trying the upgrade with composer it seems to go smoothly but when admin or web site is opened there is a big error and the exception log shows

 main.CRITICAL: Dotmailer connector API endpoint cannot be empty. {"exception":"[object] (Magento\\Framework\\Exception\\LocalizedException(code: 0): Dotmailer connector API endpoint cannot be empty.

I dont know how dot mailer could think that I had ever used it. But regardless, is there a way to upgrade and INSIST that dotmailer not be added? Or is there a fix to this issue? Work around?

Thanks in advance, Sam

2 REPLIES

Re: Upgrade to 2.2.2 prevented and Dotmailer severe issues API endpoint

I'm not sure if this was you or not but someone posted a similar error on stackexchange recently https://magento.stackexchange.com/questions/209254/dotmailer-connector-api-endpoint-cannot-be-empty.... There's no response there yet but if other people are experiencing the same problem it's likely a problem with the dotmailer extension. I'd creating an issue directly with them on their github repository: https://github.com/dotmailer/dotmailer-magento2-extension

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: Upgrade to 2.2.2 prevented and Dotmailer severe issues API endpoint

Hi @samreg @Tom Robertshaw,

 

I'm encountering same issue, if you know of a solution, I'm looking forward hearing about itSmiley Happy

kind regards