cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading from 2.0.4 to 2.06 Didn't Complete Using The System Upgrade.

Upgrading from 2.0.4 to 2.06 Didn't Complete Using The System Upgrade.

Today when I tried to upgrade my magento from 2.0.4 to 2.0.6 I got this error. And sadly I can't rollback too. Smiley Sad Could someone help me please?

 

[2016-05-18 17:30:04 WIB] Job "maintenance_mode {"enable":true}" has been started
[2016-05-18 17:30:04 WIB] Magento maintenance mode is enabled.
[2016-05-18 17:30:04 WIB] Job "maintenance_mode {"enable":true}" has successfully completed
[2016-05-18 17:30:04 WIB] Job "update {"components":[{"name":"magento/product-community-edition","version":"2.0.6"}]}" has been started
[2016-05-18 17:30:04 WIB] Starting composer update...
[2016-05-18 17:30:05 WIB] ./composer.json has been updated

[2016-05-18 17:32:11 WIB] An error occurred while executing job "update {"components":[{"name":"magento/product-community-edition","version":"2.0.6"}]}": Could not complete update {"components":[{"name":"magento/product-community-edition","version":"2.0.6"}]} successfully: Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
- Removing magento/magento-composer-installer (0.1.6)
- Installing magento/magento-composer-installer (0.1.8)
Downloading: Connecting... Downloading: 0% Downloading: 10% Downloading: 35% Downloading: 45% Downloading: 70% Downloading: 95% Downloading: 100%

[ErrorException]
escapeshellarg() has been disabled for security reasons

update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [packages1] ... [packagesN]

3 REPLIES

Re: Upgrading from 2.0.4 to 2.06 Didn't Complete Using The System Upgrade.

Could you send message in the logs file? Current information is not sufficient to detect the issue. May be you should retry the migration from your backup ?

Re: Upgrading from 2.0.4 to 2.06 Didn't Complete Using The System Upgrade.

Did you re-upgrade? What's happen? escapeshellarg() has been disabled for security reasons. Maybe some errors happen with your connector.

https://goo.gl/fcghyU

Re: Upgrading from 2.0.4 to 2.06 Didn't Complete Using The System Upgrade.

Hope someone can help! Smiley Sad