cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading from 2.3.2 to 2.3.3 problems

Highlighted

Upgrading from 2.3.2 to 2.3.3 problems

Upon trying to upgrade from 2.3.2 to 2.3.3 I'm getting the following errors:

 

composer require magento/product-community-edition 2.3.3 --update-with-all-dependencies
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- eadesignro/module-eacore 0.0.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- eadesignro/module-eacore 0.0.4 requires php ~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.20 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.19 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.18 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.17 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.16 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.15 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.14 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.13 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/framework 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.31) does not satisfy that requirement.
- magento/product-community-edition 2.3.3 requires magento/framework 102.0.3 -> satisfiable by magento/framework[102.0.3].
- eadesignro/ro_ro 1.1.2 requires eadesignro/module-eacore ~0.0.4 -> satisfiable by eadesignro/module-eacore[0.0.4, 0.0.5].
- Installation request for magento/product-community-edition 2.3.3 -> satisfiable by magento/product-community-edition[2.3.3].
- eadesignro/ro_ro 1.1.0 requires magento/framework ^100.0.0 -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.1.9, 100.0.18, 100.0.19, 100.1.10, 100.1.11, 100.0.20, 100.1.12, 100.1.13, 100.1.14, 100.1.15, 100.1.16, 100.1.17, 100.1.18].
- Can only install one of: magento/framework[102.0.3, 100.1.16].
- Can only install one of: magento/framework[102.0.3, 100.1.17].
- Can only install one of: magento/framework[102.0.3, 100.1.18].
- Installation request for eadesignro/ro_ro ^1.1 -> satisfiable by eadesignro/ro_ro[1.1.0, 1.1.2].

Please advice.

 

Thank you,

4 REPLIES 4
Highlighted

Re: Upgrading from 2.3.2 to 2.3.3 problems

Hi, after downgrading to PHP 7.0

 

    - Installation request for magento/product-community-edition 2.3.3 -> satisfiable by magento/product-community-edition[2.3.3].
    - magento/product-community-edition 2.3.3 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.0.33) does not satisfy that requirement.

any other ideas ? Smiley Wink 

Highlighted

Re: Upgrading from 2.3.2 to 2.3.3 problems

Please change php version from 7.0 to 7.1 or 7.2

Highlighted

Re: Upgrading from 2.3.2 to 2.3.3 problems

Upgrading to php 7.2 made the command to work:

/usr/local/php72/bin/php-cli composer update

Highlighted

Re: Upgrading from 2.3.2 to 2.3.3 problems

I might have solved the problem by accident. While investigating it looks like I found a working solution.
At the end of the "use" clauses in /path to website/vendor/vertex/module-tax/Model/FlexField/Processor/OrderCurrencyGetterProcessor.php add the following two lines:
use Vertex\Tax\Model\FlexField\Processor\InvoiceFlexFieldProcessorInterface;
use Vertex\Tax\Model\FlexField\Processor\TaxCalculationFlexFieldProcessorInterface;

 

This fix works for me. I was not able to successfully apply the patch given above. This only started happening after I upgraded from 2.3.2 to 2.3.3

Ubuntu 16.04.6 LTS
Magento 2.3.3
PHP 7.2.23
MySQL 5.7.27
Redis 5.0.6
Varnish 4.1.1