cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading to 2.0.1

Upgrading to 2.0.1

Trying to upgrade to 2.0.1 using the System Upgrade. On last step after clicking the Upgrade button, it just show "System Update Status: Update pending" and there's nothing in the console log.

 

 

The website is running inside Plesk CP with PHP 7.0.1. There is no error message in apache log.

18 REPLIES

Re: Upgrading to 2.0.1

I have also that Problem today:


Setup Wizzard in Magento Admin

Step 1: Select Version


Sorry, we can't take that action right now.

Re: Upgrading to 2.0.1

After pending for a long time, I got an error and the message "Update application is not running"

 

The console log is like this

[2016-01-21 13:45:56 CET] Job "maintenance_mode {"enable":true}" has been started 
[2016-01-21 13:45:56 CET] Magento maintenance mode is enabled. 
[2016-01-21 13:45:56 CET] Job "maintenance_mode {"enable":true}" has successfully completed 
[2016-01-21 13:45:56 CET] Content to write must be a valid JSON.

Re: Upgrading to 2.0.1

Is there a way to upgrade via command line?

 

1. copy new magento files

2. php bin/magento upgrade

 

Re: Upgrading to 2.0.1

The error "Sorry we can't that action" is caused by not having setup the public/private key in the configuration. 

You must login to magento connect and my account and can setup a new key. 

 

The key then gets plugged into the configuration for the updated.

 

However, I did this, and now when I attempt to click "System Upgrade" I get a 500 error in the JS console. 

 

any thoughtS?

Re: Upgrading to 2.0.1


sengh wrote:

Is there a way to upgrade via command line?

 

1. copy new magento files

2. php bin/magento upgrade

 



Yes I would also like to do this. I've been trying to upgrade for two days now and the farthest I've gotten is:

 

[2016-01-21 12:31:04 EST] Job "maintenance_mode {"enable":true}" has been started
[2016-01-21 12:31:04 EST] Magento maintenance mode is enabled.
[2016-01-21 12:31:04 EST] Job "maintenance_mode {"enable":true}" has successfully completed
[2016-01-21 12:31:05 EST] Job "update {"components":[{"name":"magento/product-community-edition","version":"2.0.1"}]}" has been started
[2016-01-21 12:31:05 EST] Starting composer update...
[2016-01-21 12:31:05 EST] ./composer.json has been updated

 

Seems to hang there. Nothing in log files. Why isn't there a log of system upgrade?

Re: Upgrading to 2.0.1

Not necessarily true. I got that error for a few minutes, on about the fifth time I was trying to upgrade. Didn't show up the first four times. I was logged into magento connect. It went away without explanation.


jvaruzzo wrote:

The error "Sorry we can't that action" is caused by not having setup the public/private key in the configuration. 

You must login to magento connect and my account and can setup a new key. 

 

The key then gets plugged into the configuration for the updated.

 

However, I did this, and now when I attempt to click "System Upgrade" I get a 500 error in the JS console. 

 

any thoughtS?


 

Re: Upgrading to 2.0.1

Obviously there is an issue with this whole "updating thing". I attempted to do it as well and the status has sat now for over an hour on "Update application is running" with the following in the console log:

[2016-01-21 17:09:03 UTC] Job "maintenance_mode {"enable":true}" has been started
[2016-01-21 17:09:03 UTC] Magento maintenance mode is enabled.
[2016-01-21 17:09:03 UTC] Job "maintenance_mode {"enable":true}" has successfully completed
[2016-01-21 17:09:03 UTC] Job "update {"components":{"magento/framework":{"name":"magento/framework","version":"100.0.3"}}}" has been started
[2016-01-21 17:09:03 UTC] Starting composer update...
[2016-01-21 17:09:03 UTC] ./composer.json has been updated

I was able to get the site back out of maintenance mode but now my images aren't loading and there are all types of issues.

 

Starting to think Magento2 is not the platform I should be going with.

Re: Upgrading to 2.0.1

May I know upgrading require Composer or not ?

Re: Upgrading to 2.0.1

Yes there is but please wait until the solution to the current 2.0.1 upgrade issues is announced. I believe it will be soon.

 

To upgrade CE:

 

composer require magento/product-community-edition 2.0.1 --no-update
composer update

 

Replace 2.0.1 with the desired version.