cancel
Showing results for 
Search instead for 
Did you mean: 

app/etc/NonComposerComponentRegistration.php version 2.0.8 and onwards

SOLVED

app/etc/NonComposerComponentRegistration.php version 2.0.8 and onwards

Running the command line / composer upgrade from CE 2.0.7 to 2.0.8 or 2.1.0 crashes at the bin/magento setup:upgrade stage complaining about NonComposerComponentRegistration.php not being found. This php file is removed by the composer update command.

 

Have tried copying the NonComposerComponentRegistration.php from 2.0.7 to see if that fixes it that, but depending on the version I get various different errors. e.g. in 2.0.8 PHP Fatal error: cannot instantiate interface Magento\Framework\Config\CacheInterface in ....../vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php:73 

 

I removed the requirement for NonComposerComponentRegistration.php in the composer.json file, but the bin/magento setup:upgrade command needs it later in the stack.

 

I went back to 2.0.7 and did a composer 2.0.7 upgrade and that worked, NonComposerComponentRegistration.php remained and the site worked fine, upgrading to a later version is not possible as per above.

 

The composer version is from May this year, and am running Ubuntu and php7 on the latest Virtualbox with no additional plugins and the default Luma theme, with 100 or so added attributes .

 

I guess I could try the back office update path, or a start from scratch install.

 

But has anyone else been able to use a Composer upgrade past 2.0.7? If so, what was your secret?

1 REPLY

Re: app/etc/NonComposerComponentRegistration.php version 2.0.8 and onwards

Well the secret was either

 

Make sure the 3 cron jobs are running

or

Make sure the owner of all the magento files is not root but the magento file system user

 

I guessed on the latter item even though the permissions link on the checklist page is broken

 

http://devdocs.magento.com/guides/v2.0/comp-mgr/prereq/prereq_compman-checklist.html

 link

http://devdocs.magento.com/guides/v2.0/install-gde/prereq/file-system-perms-over.html