cancel
Showing results for 
Search instead for 
Did you mean: 

composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found

Highlighted

composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found

hi 

i am trying to do composer update on my magento 2.3.4

and getting following error

did anybody have similar issue ?

thanks

 

error.png

4 REPLIES 4
Highlighted

Re: composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found

Problem 1
- Installation request for composer/composer @alpha -> satisfiable by composer/composer[1.10.8].
- composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found.
Problem 2
- composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found.
- magento/product-community-edition 2.3.4 requires composer/composer ^1.6 -> satisfiable by composer/composer[1.10.8].
- Installation request for magento/product-community-edition 2.3.4.0 -> satisfiable by magento/product-community-edition[2.3.4].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
- It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Highlighted

Re: composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found

Hi @michal_bnet ,

Can you please mention the content of composer.json file.

Did you ran any composer require command before composer update. If yes, please mention that command as well.

 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!

Highlighted

Re: composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found

hi @Nishu Jindal 

yes i try also composer require with some specific module.

but that doesnt matter, because even if you dont do composer require and run just composer update, it shouldnt show any error.

 

here is composer.json

 

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.2.6",
"license": [
"OSL-3.0",
"AFL-3.0"
],
"require": {
"magento/product-community-edition": "2.3.4.0",
"composer/composer": "@alpha"
},
"require-dev": {
"phpunit/phpunit": "~6.2.0",
"squizlabs/php_codesniffer": "3.2.2",
"phpmd/phpmd": "@stable",
"pdepend/pdepend": "2.5.2",
"friendsofphp/php-cs-fixer": "~2.10.1",
"lusitanian/oauth": "~0.8.10",
"sebastian/phpcpd": "~3.0.0"
},
"autoload": {
"psr-4": {
"Magento\\Framework\\": "lib/internal/Magento/Framework/",
"Magento\\Setup\\": "setup/src/Magento/Setup/",
"Magento\\": "app/code/Magento/",
"Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"
},
"psr-0": {
"": [
"app/code/",
"generated/code/"
]
},
"files": [
"app/etc/NonComposerComponentRegistration.php"
],
"exclude-from-classmap": [
"**/dev/**",
"**/update/**",
"**/Test/**"
]
},
"autoload-dev": {
"psr-4": {
"Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
"Magento\\Tools\\": "dev/tools/Magento/Tools/",
"Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
"Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
"Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
}
},
"minimum-stability": "dev",
"repositories": [
{
"type": "composer",
"url": "https://repo.magento.com/"
}
],
"extra": {
"magento-force": "override"
}
}

 

Highlighted

Re: composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found

Hi @michal_bnet ,

 

Below is the composer.json file on Vanilla Magento version 2.3.4 . I found some differences in both the files. 

As you are requiring some modules, can you try composer require command with --no-update variable and then try to run the composer update command.

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"license": [
"OSL-3.0",
"AFL-3.0"
],
"config": {
"preferred-install": "dist",
"sort-packages": true
},
"require": {
"magento/product-community-edition": "2.3.4"
},
"require-dev": {
"allure-framework/allure-phpunit": "~1.2.0",
"dealerdirect/phpcodesniffer-composer-installer": "^0.5.0",
"friendsofphp/php-cs-fixer": "~2.14.0",
"lusitanian/oauth": "~0.8.10",
"magento/magento-coding-standard": "~4.0.0",
"magento/magento2-functional-testing-framework": "2.5.3",
"pdepend/pdepend": "2.5.2",
"phpcompatibility/php-compatibility": "^9.3",
"phpmd/phpmd": "@stable",
"phpunit/phpunit": "~6.5.0",
"sebastian/phpcpd": "~3.0.0",
"squizlabs/php_codesniffer": "~3.4.0"
},
"conflict": {
"gene/bluefoot": "*"
},
"autoload": {
"psr-4": {
"Magento\\Framework\\": "lib/internal/Magento/Framework/",
"Magento\\Setup\\": "setup/src/Magento/Setup/",
"Magento\\": "app/code/Magento/",
"Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"
},
"psr-0": {
"": [
"app/code/",
"generated/code/"
]
},
"files": [
"app/etc/NonComposerComponentRegistration.php"
],
"exclude-from-classmap": [
"**/dev/**",
"**/update/**",
"**/Test/**"
]
},
"autoload-dev": {
"psr-4": {
"Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
"Magento\\Tools\\": "dev/tools/Magento/Tools/",
"Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
"Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
"Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
}
},
"version": "2.3.4",
"minimum-stability": "stable",
"repositories": [
{
"type": "composer",
"url": "https://repo.magento.com/"
}
],
"extra": {
"magento-force": "override"
}
}