cancel
Showing results for 
Search instead for 
Did you mean: 

erro on update 2.1.9 to 2.2.0 error

erro on update 2.1.9 to 2.2.0 error

Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/product-community-edition 2.2.0 -> satisfiable by magento/product-community-edition[2.2.0].
- eadesignro/module-eacore 0.0.4 requires magento/module-backend ~100.1.0 -> satisfiable by magento/module-backend[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4].
- Can only install one of: magento/module-backend[100.2.0, 100.1.0-rc1].
- Can only install one of: magento/module-backend[100.2.0, 100.1.0-rc2].
- Can only install one of: magento/module-backend[100.2.0, 100.1.0-rc3].
- Can only install one of: magento/module-backend[100.2.0, 100.1.0].
- Can only install one of: magento/module-backend[100.2.0, 100.1.1].
- Can only install one of: magento/module-backend[100.2.0, 100.1.2].
- Can only install one of: magento/module-backend[100.2.0, 100.1.3].
- Can only install one of: magento/module-backend[100.2.0, 100.1.4].
- eadesignro/module-pdfgenerator 1.0.30 requires eadesignro/module-eacore ^0.0.4 -> satisfiable by eadesignro/module-eacore[0.0.4].
- magento/product-community-edition 2.2.0 requires magento/module-backend 100.2.0 -> satisfiable by magento/module-backend[100.2.0].
- Installation request for eadesignro/module-pdfgenerator 1.0.30 -> satisfiable by eadesignro/module-pdfgenerator[1.0.30].

1 REPLY

Re: erro on update 2.1.9 to 2.2.0 error

You have a module from (pdfgenerator) that has not been updated to Magento 2.2. Contact EaDesign and ask for an update or remove the module before updating.