cancel
Showing results for 
Search instead for 
Did you mean: 

update from 2.1.3 to 2.2

update from 2.1.3 to 2.2

can anyone help me how to update from magento 2.1.3 to 2.2.1

Tags (1)
5 REPLIES

Re: update from 2.1.3 to 2.2

Hi @marianaNc,

 

Maybe you can try moving first to 2.1.10 (you'll find, maybe, some small issues if the frontend code wasn't good enough).

You can perform that upgrade just with composer:

 

composer require magento/product-community-edition 2.1.10 --no-update
composer update

And then, moving to 2.2.1 (with composer too).

In theory you should be able to perform the upgrade in the same way (I didn't tried my self yet and I've saw a few cases with problems, byt it should work).

 

Remember to backup yoru code and database before.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: update from 2.1.3 to 2.2

I have just recently upgrade from Magento 2.1.3 to 2.2.1 version of magento.

 

You just need to do simple process, go to composer.json file from magento setup root path,

change below line,

"version": "2.1.3"  To "version": "2.2.1"
"magento/product-community-edition": "2.1.3" to "magento/product-community-edition": "2.2.1",

Just set your latest version instead of older version in composer.json file.

 

Now login with SSH to run command,

composer update

After waiting of 15-30 minutes your version will upgraded to latest version.

 

Now run command to check latest version,

php binn/magento setup:upgrade
php binn/magento setup:static-content:deploy -f
php binn/magento cace:flush

if issue solved, Click Kudos/Accept as solutions.

If Issue Solved, Click Kudos/Accept As solutions.

Re: update from 2.1.3 to 2.2

I did all these steps and now I got this error on the website

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Please update your modules: Run "composer install" from the Magento root directory.
The following modules are outdated:
Magento_Customer db data version: defined in codebase - 2.0.12, currently installed - 2.0.9

Exception #0 (Magento\Framework\Exception\LocalizedException): Please update your modules: Run "composer install" from the Magento root directory.
The following modules are outdated:
Magento_Customer db data version: defined in codebase - 2.0.12, currently installed - 2.0.9
#0 /home/cottonlinen/public_html/vendor/magento/framework/Interception/Interceptor.php(121): Magento\Framework\Module\Plugin\DbStatusValidator->beforeDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Magento\Framework\App\Request\Http))
#1 /home/cottonlinen/public_html/vendor/magento/module-page-cache/Model/App/FrontController/BuiltinPlugin.php(73): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#2 /home/cottonlinen/public_html/vendor/magento/framework/Interception/Interceptor.php(135): Magento\PageCache\Model\App\FrontController\BuiltinPlugin->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#3 /home/cottonlinen/public_html/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#4 /home/cottonlinen/public_html/generated/code/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, Array)
#5 /home/cottonlinen/public_html/vendor/magento/framework/App/Http.php(135): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#6 /home/cottonlinen/public_html/vendor/magento/framework/App/Bootstrap.php(256): Magento\Framework\App\Http->launch()
#7 /home/cottonlinen/public_html/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#8 {main}

can you help me to solve it

Re: update from 2.1.3 to 2.2

Same issue upgraded from 2.1.9 to 2.2

 

There has been an error processing your request

Please update your modules: Run "composer install" from the Magento root directory.
The following modules are outdated:
Magento_Customer db data version: defined in codebase - 2.0.12, currently installed - 2.0.9

Re: update from 2.1.3 to 2.2

You need to first run command,

composer install

in your error they shows to install composer, Using this command you can get latest components which are added recently.

 

After successfully run above command do the same procedure for update version of magento using change composer.json file version change to latest and run again,

composer update
If Issue Solved, Click Kudos/Accept As solutions.