cancel
Showing results for 
Search instead for 
Did you mean: 

upgrade 2.4.7 to 2.4.7-p1

upgrade 2.4.7 to 2.4.7-p1

Hello.

I have installed magento 2.4.7 on a local system using Composer . since recent security issue , want to upgrade to 2.4.7-p1 .

followed the upgrade .

composer require-commerce magento/community-edition 2.4.7-p1 --no-update and I keep getting following issue.

  Problem 1
    - Root composer.json requires magento/community-edition 2.4.7-p1 -> satisfiable by magento/community-edition[2.4.7-p1].
    - magento/product-community-edition 2.4.7 requires magento/framework 103.0.7 -> satisfiable by magento/framework[103.0.7].
    - Only one of these can be installed: magento/framework[100.0.2, ..., 100.1.18, 101.0.0, ..., 101.0.11, 102.0.0, ..., 102.0.7-p3, 103.0.0, ..., 103.0.7-p1], magento/community-edition[2.4.7-p1]. magento/community-edition replaces magento/framework and thus cannot coexist with it.
    - Root composer.json requires magento/product-community-edition 2.4.7 -> satisfiable by magento/product-community-edition[2.4.7].

this is my first time upgrading . have searched and could not find how to resolve and upgrade the local development .

any suggestion would be appreciated.

 

Thanks.

Linux ubuntu , php 8.1 , apache2

2 REPLIES 2

Re: upgrade 2.4.7 to 2.4.7-p1

@tonysargma79f8 

 

Hey,

 

Please replace require-dev section of composer.json files with below given file : https://github.com/magento/magento2/blob/2.4.7-p1/composer.json,
Then try to run composer update
--ignore-platform-reqs

 

Thank You!

Problem solved? Click Kudos and "Accept as Solution".
200+ Magento 2 Extensions for Enhanced Shopping Experience.

Re: upgrade 2.4.7 to 2.4.7-p1

Thanks.

my compser.json , has the same exact information for require-dev with composer.json on github.