cancel
Showing results for 
Search instead for 
Did you mean: 

reset permission settings - magmi

SOLVED

reset permission settings - magmi

Hello Forum:

I made a fatal and embarrassing error in installing MAGMI (using UndertandingE magmi-installer).  I mis-read the instructions for permission settings and entered incorrect numbers.  Now I am locked out of magmi.  I reached out to UnderstandingE, but unfortunately, no one has gotten back to me.

I attempted to delete the magmi folders with the thought that I could delete and re-install.  However, I unable to delete the folders from my C-panel and FileZilla gives me the following error, “550 Can't remove directory: Directory not empty”.  So I am stuck.   Can someone help me delete the files or help me reset the permissions?

The permission settings currently in C-panel and FileZilla are listed below

C-panel:

magmi-importer = 755

magmi-importer / web = 644

var = 777

var/cache = 0777

var/cache/all files = 777

var/log = 0750

var/log/all files = 640 

var/session = 777

var/session/all files = 600

 

FileZilla:

magmi-importer = 755

magmi-importer / web = Access denied.  Response: 550 can't change directory to web: permission denied.  Error: failed to retrieve directory listing

var = 777

var/cache = 0777

var/cache/all files = 777

var/locks =777

var/locks/all files =666

var/log = 0750

var/log/all files = 640 

var/session = 777

var/session/all files = 600

1 REPLY

Re: reset permission settings - magmi

Dear Forum:
Please disregard my post. I was able to solve the problem. The issue was isolated to the web folder - all of the files contained within had no permission settings. So I set each file permission to 0644, and I now have access to magmi again.
Thanks,
Michelle