Your requirements could not be resolved to an installable set of packages.
- Root composer.json requires mollie/magento2 ^2.12 -> satisfiable by mollie/magento2[2.12.0].
- mollie/magento2 2.12.0 requires magento/framework >=102.0.3 -> could not be found in any version, there may be a typo in the package name.
After searching I found the following thread here. But that also does not help me. I tried setting the following: