cancel
Showing results for 
Search instead for 
Did you mean: 

Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

Я не могу разобраться, насколько важно для работы сайта установка Magento Security Patch SUPEE 5344 and 1533. У меня сайт версия 1.5.1.0. Если я не установлю это, могут возникнуть проблемы?

Могу ли я, не специалист, а обычный пользователь, самостоятельно установить эти патчи? Или без специалиста  не обойтись?

Сможет мне кто-то помочь эти патчи установить, и сколько эта услуга стоит?

 

47 REPLIES

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

Данные патчи исправляют потенциальную возможность злоумышленнику выполнить свой код у вас на сервере.

В идеале всегда пользоваться последними версиями ПО и применять все патчи безопасности. Это хоть и не гарантирует 100% защиту от взлома, но самые известные дырки будут прикрыты.

 

Патчи установить не сложно, но это занимает время. В среднем нужно около часа, что применить патчи на сайт (на каком-то сервере хватает 15 минут с учётом получения доступов на сервер, а где-то и в 2 часа сложно уложиться, если код ядра модифицирован или нет полного доступа к серверу).

 

Если у вас есть ssh доступ к серверу, то надо закачать файлы патчей в корень сайта и запустить команду 

sh PATCH_FILE_NAME.sh

 

Если патч не устанавливается, то или у вас не хватает прав или нет каких-то утилит на сервере или файлы ядра отличаютсяот того, что ожидвает увидеть патч. В этом случае вы можете найти уже пропатченные файлы для вашей версии (маловероятно) или внести изменения в файлы вручную. Вся информация о том, что и на что менять доступна в патче.

 

Стоимость услуги зависит от стоимости часа работы исполнителя.


ET Web Solutions
extensions, custom work, support

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

Добрый день!

При установке патчей через SSH, выдает следующее сообщение. Возможно ктото сталкивался?

 

Some required system tools, that are utilized in this sh script, are not installed.

Tool patch is missed, please install it.

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

На сервер надо установить утилиту "patch".

 

https://ru.wikipedia.org/wiki/Patch_%28UNIX%29


ET Web Solutions
extensions, custom work, support

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

Спасибо, огромное!

Не подскажите, утилиту можно установить самостоятельно или необходимо обратиться в поддержку хостинга?

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

Надёжнее обратиться в поддержку хостинга.


ET Web Solutions
extensions, custom work, support

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

Оказывается на вируальном сервере подобные манипуляции не предусмотрены. Подскажите, есть ли способ применить изменения без выполнения команд по SSH?

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

Второй вариат:

внести изменения в файлы вручную. Какие строки и в каких файлах поменять можно выковырять из патча. Займёт больше времени и требует внимательности.

 

Третий вариант: 

пропатчить Magento на другом хостинге и переписать на ваш пропатченные файлы.

 


ET Web Solutions
extensions, custom work, support

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0

третий вариант не прокатит.

Кроме файлов патч может вносить изменения в и БД, их обычным копированием не заменить.

Re: Помогите установить Magento Security Patch SUPEE 5344 and 1533 для Magento вер. 1.5.1.0


KEINrus wrote:

третий вариант не прокатит.

Кроме файлов патч может вносить изменения в и БД, их обычным копированием не заменить.


Данные патчи в базу данных изменений не вносят.


ET Web Solutions
extensions, custom work, support