cancel
Showing results for 
Search instead for 
Did you mean: 

Совместимость Magento 1 с PHP 7.0 и 7.1

Совместимость Magento 1 с PHP 7.0 и 7.1

Привет!

 

Совместима ли Magento 1 с PHP 7.0 и 7.1? Если да, то с какими именно.

 

Благодарю за ответ!

5 REPLIES

Re: Совместимость Magento 1 с PHP 7.0 и 7.1

Для Magento Enterprise Edition и Community Edition официально рекомендовано использовать:

 

  • PHP 5.4.x
  • PHP 5.5.x

-----

 И это Ваши слова с одного из постов на тутошнем форуме.

Re: Совместимость Magento 1 с PHP 7.0 и 7.1

Я это знаю, то что разработчик там написал.

 

Есть люди которые говорят, что у них хорошо работает Мадженто 1 на PHP 7. Поэтому и спрашиваю, может какие-то версии PHP 7.0 и 7.1 можно использовать как-то. Или разработчик забыл обновить информацию на сайте. Времени прошло уже много, а у них написано, что совместима только с PHP 5.4.x, PHP 5.5.x, PHP 5.6.x. 

 

Re: Совместимость Magento 1 с PHP 7.0 и 7.1

На PHP7 c незначительными доработками можно запустить Magento 1.7, 1.8, 1.9 и работать будет все значительно быстрее. Но...

Но - это когда вы плохо владеете PHP и не сможете сами переписать сторонние модули.

Но - это когда у вас не свой сервер, а хостинг и модули требуют IonCube, memcached или каких то прочих серверных дополнений новой версии, хостера вряд ли сможете переубедить поставить то что нужно именно вам

Re: Совместимость Magento 1 с PHP 7.0 и 7.1

Работают с версии 1.9.3.х . Более ранние не работают.

http://smartceo.ru
Методология организации интернет-торговли, технические решения, консалтинг.

Re: Совместимость Magento 1 с PHP 7.0 и 7.1

1.8 работает тоже 100%

 

Еще один нежданчик сегодня выскачил, пытался обновить через админку с 1.9.3.3 до 1.9.3.4 и получил кукишь

CONNECT ERROR: Package community 1.9.3.4: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.18

Будьте внимательны на PHP7 штатными средствами обновиться не получится