cancel
Showing results for 
Search instead for 
Did you mean: 

проблема при установке magento

проблема при установке magento

здравствуйте. подскажите в чем ошибка? скачал с сайта( https://www.magentocommerce.com/download ) дистрибутив magento ver 2.1.1 > распаковал > установил денвер > в его вирт. диске в папке home создал свою папку по названию сайта (имя.сом) > создал папку www > в нее скопировал распакованные файлы и папки magento > в ком. строке хрома (оперы) ввожу название сайта , а мне пишет "Magento supports PHP 5.6, 7.0.2, and 7.0.6 or later. Please read Magento System Requirements" .

скачал версию 2.0.9. при первом запуске пишет "Magento supports PHP 5.5.0 or later. Please read Magento System Requirements."

 

базу данных создал без проблем.

8 REPLIES

Re: проблема при установке magento

В Денвер старая версия PHP, пробуйте поставить XAMPP с PHP не ниже 5.6
В идеале ставьте Magento на Linux

Re: проблема при установке magento

Можно попробовать установить OpenServer в отличии от Denver эта платформа еще поддерживается разработчиком (обновляется). Но лучше всего установить на ПК виртуальную машину. например бесплатную VirtualBox , и уже в ней установить ОС Linux - Ubuntu . Далее устанавливаем связку программ Apache. PHP. MySQL  требования Magento смотрим здесь Наладка Ubuntu для работы с сайтами на локальном сервере  Google translate Вам в помощь Smiley Wink Почитать как установить сборку можно еще здесь Локальный сервер Xampp на Linux Ubuntu, скажу сразу, статья малость устарела но принцип остался тем же. Скачать программу Xampp здесь , кстати она работает и под ОС Windows. В прочем Google или Яндекс поиск Вам в помощь. Удачи Вам в Ваших начинаниях.

Я не программист, всего лишь продвинутый пользователь. Smiley Wink

Re: проблема при установке magento

Разобрался. пробовал ставить хамрр, не понравился. какой то он "корявенький". поставил open server. Прелесть. В его настройках прямым текстом написано что windows xp поддерживает до версии 5.5. Нужна семерка. сейчас переустановлю. С виртуальной машиной не оч. охота связываться. Всем спасибо.

Re: проблема при установке magento

опять проблемка появилась. при инициализации магенто выводит ошибку 

PHP Extensions Check

1 missing PHP extensions.

пробовал изменять версии php от 5.5 до 7.0 пробовал magento 2.0.9 и 2.1.1, результат тот же. Что не так?1.png

Re: проблема при установке magento

опять проблемка появилась. при инициализации магенто выводит ошибку 

PHP Extensions Check

1 missing PHP extensions.

пробовал изменять версии php от 5.5 до 7.0 пробовал magento 2.0.9 и 2.1.1, результат тот же. Что не так?22.jpg

Re: проблема при установке magento

 


eagleman19 wrote:

опять проблемка появилась. при инициализации магенто выводит ошибку 

PHP Extensions Check

1 missing PHP extensions.

пробовал изменять версии php от 5.5 до 7.0 пробовал magento 2.0.9 и 2.1.1, результат тот же. Что не так?22.jpg


Версии php тут не причем. У Вас не включено какое-то расширение PHP. а для того чтоб узнать какое именно нужно посмотреть в ошибки лог файла - корневая папка вашего сайта\var\log\system 
Но подозреваю что не включено расширение php_intl.dll
Если я угадал то кликнете мышкой по флажку сервера, выбираете в меню дополнительно, далее конфигурация, далее PHP 5.6 (или какая там у Вас версия) и находите следующее
 php_intl.gif
убираете точку с запятой в начале строки (т.е. комментарий) 
тем самым вы включаете данное расширение.
НЕ ЗАБУДЬТЕ ПЕРЕЗАПУСТИТЬ СЕРВЕР!

Я не программист, всего лишь продвинутый пользователь. Smiley Wink

Re: проблема при установке magento

да спасибо, проблема была в этом

Re: проблема при установке magento

Всегда пожалуйста Smiley Happy

Я не программист, всего лишь продвинутый пользователь. Smiley Wink