cancel
Showing results for 
Search instead for 
Did you mean: 

No puedo instalar Magento 1.9.2.2

No puedo instalar Magento 1.9.2.2

Buenas noches Grupo

 

A la hora de instalar Magento 1.9.2.2 me sale el siguiente error:

 

There has been an error processing your request

Exception printing is disabled by default for security reasons.

Error log record number: 1124663408

 

Muchas gracias

3 REPLIES

Re: No puedo instalar Magento 1.9.2.2

Ese mensaje únicamente te indica que ha habido un error.

Para saber el error real, debes ir a la carpeta var/report dentro de tu instalación de magento y buscar un archivo con el mismo número de error que te aparece en pantalla. En el caso anterior sería:

var/report/1124663408

Allí tendrás una descripción un poco más precisa de lo que ocurre.

Re: No puedo instalar Magento 1.9.2.2

a:5:{i:0;s:2075:"Error in file: "C:\xampp\htdocs\magento\app\code\core\Mage\SalesRule\sql\salesrule_setup\install-1.6.0.0.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'salesrule' already exists, query was: CREATE TABLE `salesrule` (
`rule_id` int UNSIGNED NOT NULL auto_increment COMMENT 'Rule Id' ,
`name` varchar(255) NULL COMMENT 'Name' ,
`description` text NULL COMMENT 'Description' ,
`from_date` date NULL COMMENT 'From Date' ,
`to_date` date NULL COMMENT 'To Date' ,
`uses_per_customer` int NOT NULL default '0' COMMENT 'Uses Per Customer' ,
`customer_group_ids` text NULL COMMENT 'Customer Group Ids' ,
`is_active` smallint NOT NULL default '0' COMMENT 'Is Active' ,
`conditions_serialized` mediumtext NULL COMMENT 'Conditions Serialized' ,
`actions_serialized` mediumtext NULL COMMENT 'Actions Serialized' ,
`stop_rules_processing` smallint NOT NULL default '1' COMMENT 'Stop Rules Processing' ,
`is_advanced` smallint UNSIGNED NOT NULL default '1' COMMENT 'Is Advanced' ,
`product_ids` text NULL COMMENT 'Product Ids' ,
`sort_order` int UNSIGNED NOT NULL default '0' COMMENT 'Sort Order' ,
`simple_action` varchar(32) NULL COMMENT 'Simple Action' ,
`discount_amount` decimal(12,4) NOT NULL default '0.0000' COMMENT 'Discount Amount' ,
`discount_qty` decimal(12,4) NULL COMMENT 'Discount Qty' ,
`discount_step` int UNSIGNED NOT NULL COMMENT 'Discount Step' ,
`simple_free_shipping` smallint UNSIGNED NOT NULL default '0' COMMENT 'Simple Free Shipping' ,
`apply_to_shipping` smallint UNSIGNED NOT NULL default '0' COMMENT 'Apply To Shipping' ,
`times_used` int UNSIGNED NOT NULL default '0' COMMENT 'Times Used' ,
`is_rss` smallint NOT NULL default '0' COMMENT 'Is Rss' ,
`website_ids` text NULL COMMENT 'Website Ids' ,
`coupon_type` smallint UNSIGNED NOT NULL default '1' COMMENT 'Coupon Type' ,
PRIMARY KEY (`rule_id`),
INDEX `IDX_SALESRULE_IS_ACTIVE_SORT_ORDER_TO_DATE_FROM_DATE` (`is_active`, `sort_order`, `to_date`, `from_date`)
) COMMENT='Salesrule' ENGINE=INNODB charset=utf8 COLLATE=utf8_general_ci";i:1;s:944:"#0 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(644): Mage::exception('Mage_Core', 'Error in file: ...')
#1 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '1.6.0.3')
#2 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb('1.6.0.3')
#3 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Model\App.php(428): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Model\App.php(354): Mage_Core_Model_App->_initModules()
#6 C:\xampp\htdocs\magento\app\Mage.php(684): Mage_Core_Model_App->run(Array)
#7 C:\xampp\htdocs\magento\index.php(83): Mage::run('', 'store')
#8 {main}";s:3:"url";s:9:"/magento/";s:11:"script_name";s:18:"/magento/index.php";s:4:"skin";s:7:"default";}

Re: No puedo instalar Magento 1.9.2.2

La explicación corta es que ha fallado el instalador y, o bien reinstalas o bien, si tienes certeza que la tabla existe, modificas a mano el valor de la versión en la tabla core_resource para ese módulo.

 

La explicación extensa, es que Magento ejecuta los scripts de instalación (ya sea lo de estrucutra de datos o la de datos) y una vez que lo hace, escribe en la tabla core_resource la versión actualmente instalada de cada módulo.

De esa manera, si luego detecta que tienes código con una versión superior a la informada por la tabla core_resource, ejecuta dicho script y te actualiza a la última versión.

Normalmente, estos fallos pueden darse por un script de instalación mal programado (en el caso de módulos custom). Si ha fallado con un módulo core, es muy probable que la falla haya sido por tu stack de software (por ejemplo, se quedó sin memoria y se interrumpió el proceso y luego reintentó la instalación pero la tabla existía y core_resource no había alcanzado a guardar la versión final instalada).

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"