cancel
Showing results for 
Search instead for 
Did you mean: 

HMTL Head code not displaying

SOLVED
Highlighted
Occasional Contributor

HMTL Head code not displaying

I have a fresh install of 2.1 with a theme installed (Ultimo by Infortis). I'm trying to add a line of code in in HTML Head but it is not working. I'm using these instructions:

 

In Magento 2.1 go to:
Content > Design > Configuration > HTML Head

In the “Scripts and Style Sheets” field add the following line:

<link  rel="stylesheet" type="text/css"  media="all" href="{{MEDIA_URL}}my_styles.css" /> 

The file “my_styles.css” containing your custom CSS styles needs to be placed in the media folder:

pub\media\my_styles.css

 

.....

 

After following the instructions above, it did not work. So I’ve cleared all the cache and cache storage, and also tried rebuilding the Magento static files at the command line, using the following command:

bin/magento setup:static-content:deploy

 

I’m not necessarily 100% confident I did that correctly. It looked like it ran correctly, as it said it deployed all files at the end of running, but running that command is new to me.

 

After all of this, the new line of code still does not show up when I view source code on the site. I've used Incognito mode to make sure the site wasn't cached in a browser. What should I try next?

  • CE 2.1
1 REPLY
Occasional Contributor

Re: HMTL Head code not displaying

I think I got it... the config was set to Single Store. I changed that to No and then went in to the Store config settings and it seems to have fixed it. The new line of code is now displaying in the source code.