cancel
Showing results for 
Search instead for 
Did you mean: 

2.1.10 to 2.2.1 issue

SOLVED
Highlighted
Contributor

2.1.10 to 2.2.1 issue

php 7.0

 

try to update magento 2.1.10 to 2.2.1 via composer

composer require magento/product-community-edition 2.2.1 --no-update
composer update

And get next error

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - fooman/ordernumbercustomiser-m2 2.2.0 requires magento/module-sales ^100.0.2 -> satisfiable by magento/module-sales[100.1.9, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.0.8, 100.0.9, 100.1.1, 100.0.10, 100.1.2, 100.1.3, 100.0.11, 100.1.4, 100.0.12, 100.1.5, 100.0.13, 100.1.6, 100.0.14, 100.1.7, 100.2.0-rc20, 100.1.8, 100.0.15, 100.0.16].
    - fooman/ordernumbercustomiser-m2 2.2.0 requires magento/module-sales ^100.0.2 -> satisfiable by magento/module-sales[100.1.9, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.0.8, 100.0.9, 100.1.1, 100.0.10, 100.1.2, 100.1.3, 100.0.11, 100.1.4, 100.0.12, 100.1.5, 100.0.13, 100.1.6, 100.0.14, 100.1.7, 100.2.0-rc20, 100.1.8, 100.0.15, 100.0.16].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.9].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.2].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.3].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.4].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.5].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.6].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.7].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.0-rc1].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.0-rc2].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.0-rc3].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.0].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.8].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.9].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.1].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.10].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.2].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.3].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.11].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.4].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.12].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.5].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.13].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.6].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.14].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.7].
    - Can only install one of: magento/module-sales[101.0.1, 100.2.0-rc20].
    - Can only install one of: magento/module-sales[101.0.1, 100.1.8].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.15].
    - Can only install one of: magento/module-sales[101.0.1, 100.0.16].
    - Can only install one of: magento/module-sales[100.1.9, 101.0.1].
    - magento/product-community-edition 2.2.1 requires magento/module-sales 101.0.1 -> satisfiable by magento/module-sales[101.0.1].
    - Installation request for magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1].
    - Installation request for fooman/ordernumbercustomiser-m2 2.2.0 -> satisfiable by fooman/ordernumbercustomiser-m2[2.2.0].

Please advise how to fix this issue.

3 REPLIES
Magento Master

Re: 2.1.10 to 2.2.1 issue

Thanks for using our extension!

 

Composer highlights that the currently installed version of Order Number Customiser would not be compatible with the version of Magento that you are trying to install. To prevent potential breakage Composer presents this message instead.

 

You will need at least Order Number Customiser 4.1.0 for Magento 2.2.
If you are still in your support period for the extension the below sequence of commands will update the extension at the same time as the upgrade to Magento:

 

composer require magento/product-community-edition 2.2.1 --no-update
composer require fooman/ordernumbercustomiser-m2:^5.0
--no-update
composer update

 Please note that if you previously downloaded the zip file you would need to log in again on our website to obtain the latest version.

If you have any further questions please don't hesitate to reach out directly to our support@fooman.co.nz email address.

Contributor

Re: 2.1.10 to 2.2.1 issue

I try your solution.

But it shows me another error.

 

http://prntscr.com/hamsj9

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package fooman/ordernumbercustomiser-m2 ^5.0 exists as fooman/ordernumbercustomiser-m2[2.2.0, 2.1.1] but these are rejected by your constraint.

Please advise.

Magento Master

Re: 2.1.10 to 2.2.1 issue

Thanks for getting in touch via our support email. The update needed to be downloaded from our site first before Composer could find it.