cancel
Showing results for 
Search instead for 
Did you mean: 

update now error

SOLVED
Occasional Contributor

update now error

Readiness Check

PHP Version Check

Server failed to respond. Please try again.

Your PHP version is 7.1.8. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6. Show detail Hide detail

 

Ok i'm on cpanel and everything is set to php 7.02 and yes the server is 7.1 is magento ever going to get current with php i need this issue resolved just started after i upgraded to 2.1.8

4 REPLIES
Moderator
Magento
E-Commerce

Re: update now error

Magento 2 is not supported PHP 7.1.8 version yet.

 

You need to downgrade php version to php 7.0.2 or 7.0.6 to install magento 2.

 

After install php 7.0.2 or 7.0.6 you can install your setup of magento.

 

You can refer this link for more info of php and mysql version, System Requirement for install magento

 

Thanks.

 

if issue solved,Click kudos/Accept as solutions.

Occasional Contributor

Re: update now error

I'm running on cpanel and do have php 7 for this domain the rest of the server is running php7.1 so i don't have a clue where it's pulling the info from didn't have this issue prior to the update

Occasional Contributor

Re: update now error

here is my php.ini

 

; cPanel-generated php ini directives, do not edit
; Manual editing of this file may result in unexpected behavior.
; To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
; For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)

allow_url_fopen = On
allow_url_include = On
display_errors = Off
enable_dl = Off
file_uploads = On
max_execution_time = 30
max_input_time = 60
max_input_vars = 1000
memory_limit = 768M
session.gc_maxlifetime = 1440
session.save_path = "/var/cpanel/php/sessions/ea-php70"
upload_max_filesize = 128M

inside public_html php.ini

; cPanel-generated php ini directives, do not edit
; Manual editing of this file may result in unexpected behavior.
; To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
; For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)

Highlighted
Occasional Contributor

Re: update now error

got it to update to 2.1.8 but now the issue after update is

 

[2017-08-11 18:46:01 UTC] Job "maintenance_mode {"enable":true}" has been started
[2017-08-11 18:46:01 UTC] Magento maintenance mode is enabled.
[2017-08-11 18:46:01 UTC] Job "maintenance_mode {"enable":true}" has successfully completed
[2017-08-11 18:46:01 UTC] Job "setup:cache:disable []" has started
Changed cache status:
config: 1 -> 0
layout: 1 -> 0
block_html: 1 -> 0
collections: 1 -> 0
reflection: 1 -> 0
db_ddl: 1 -> 0
eav: 1 -> 0
customer_notification: 1 -> 0
full_page: 1 -> 0
config_integration: 1 -> 0
config_integration_api: 1 -> 0
translate: 1 -> 0
config_webservice: 1 -> 0

[2017-08-11 18:46:01 UTC] Job "setup:cache:disable []" has been successfully completed
[2017-08-11 18:47:01 UTC] Job "update {"components":{"bsscommerce/configuable-grid-view":{"name":"bsscommerce/configuable-grid-view","version":"1.0.3"},"fme/banners":{"name":"fme/banners","version":"1.0.4"},"fme/quickrfq":{"name":"fme/quickrfq","version":"1.0.6"},"iwd/opc":{"name":"iwd/opc","version":"2.0.2"}}}" has been started
[2017-08-11 18:47:01 UTC] Job "update {"components":{"bsscommerce/configuable-grid-view":{"name":"bsscommerce/configuable-grid-view","version":"1.0.3"},"fme/banners":{"name":"fme/banners","version":"1.0.4"},"fme/quickrfq":{"name":"fme/quickrfq","version":"1.0.6"},"iwd/opc":{"name":"iwd/opc","version":"2.0.2"}}}" has been started
[2017-08-11 18:47:01 UTC] Starting composer update...
[2017-08-11 18:47:01 UTC] Starting composer update...
[2017-08-11 18:47:01 UTC] ./composer.json has been updated

[2017-08-11 18:47:01 UTC] ./composer.json has been updated

[2017-08-11 18:47:18 UTC] An error occurred while executing job "update {"components":{"bsscommerce/configuable-grid-view":{"name":"bsscommerce/configuable-grid-view","version":"1.0.3"},"fme/banners":{"name":"fme/banners","version":"1.0.4"},"fme/quickrfq":{"name":"fme/quickrfq","version":"1.0.6"},"iwd/opc":{"name":"iwd/opc","version":"2.0.2"}}}": Could not complete update {"components":{"bsscommerce/configuable-grid-view":{"name":"bsscommerce/configuable-grid-view","version":"1.0.3"},"fme/banners":{"name":"fme/banners","version":"1.0.4"},"fme/quickrfq":{"name":"fme/quickrfq","version":"1.0.6"},"iwd/opc":{"name":"iwd/opc","version":"2.0.2"}}} successfully: Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for bsscommerce/configuable-grid-view 1.0.3 -> satisfiable by bsscommerce/configuable-grid-view[1.0.3].
- bsscommerce/configuable-grid-view 1.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.8) does not satisfy that requirement.
Problem 2
- Installation request for fme/banners 1.0.4 -> satisfiable by fme/banners[1.0.4].
- fme/banners 1.0.4 requires php ~5.6.0|~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.8) does not satisfy that requirement.
Problem 3
- Installation request for fme/quickrfq 1.0.6 -> satisfiable by fme/quickrfq[1.0.6].
- fme/quickrfq 1.0.6 requires php ~5.6.0|~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.8) does not satisfy that requirement.
Problem 4
- Installation request for iwd/opc 2.0.2 -> satisfiable by iwd/opc[2.0.2].
- iwd/opc 2.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.8) does not satisfy that requirement.
Problem 5
- swissup/theme-editor 1.0.0 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.8) does not satisfy that requirement.
- swissup/theme-editor 1.0.0 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.8) does not satisfy that requirement.
- Installation request for swissup/theme-editor 1.0.0 -> satisfiable by swissup/theme-editor[1.0.0].


[2017-08-11 18:47:26 UTC] Loading composer repositories with package information
Updating dependencies (including require-dev)
- Installing bsscommerce/configuable-grid-view (1.0.3)
Downloading: Connecting... Downloading: 0% Downloading: 80% Downloading: 100%

- Installing fme/banners (1.0.4)
Downloading: Connecting... Downloading: 0%  Downloading: 5% Downloading: 10% Downloading: 15% Downloading: 70% Downloading: 75% Downloading: 80% Downloading: 85% Downloading: 90% Downloading: 95% Downloading: 100%

- Installing fme/quickrfq (1.0.6)
Downloading: Connecting... Downloading: 0%  Downloading: 20% Downloading: 100%

- Installing iwd/opc (2.0.2)
Downloading: Connecting... Downloading: 0%  Downloading: 50% Downloading: 55% Downloading: 95% Downloading: 100%

Package fabpot/php-cs-fixer is abandoned, you should avoid using it. Use friendsofphp/php-cs-fixer instead.
Writing lock file
Generating autoload files

[2017-08-11 18:47:26 UTC] Composer update completed successfully
[2017-08-11 18:47:26 UTC] Job "update {"components":{"bsscommerce/configuable-grid-view":{"name":"bsscommerce/configuable-grid-view","version":"1.0.3"},"fme/banners":{"name":"fme/banners","version":"1.0.4"},"fme/quickrfq":{"name":"fme/quickrfq","version":"1.0.6"},"iwd/opc":{"name":"iwd/opc","version":"2.0.2"}}}" has successfully completed
[2017-08-11 18:48:02 UTC] There was an error in previous Update attempt.
[2017-08-11 18:48:02 UTC] There was an error in previous Update attempt.