Showing results for 
Search instead for 
Did you mean: 

Import configurable products in Magento 2

Import configurable products in Magento 2

Is there a new way in Magento 2 to import configurable products? With magento 2 in the admin panel, I know it creates the simples as part of adding a configurable product. Can this be done via an import, where simple and configurables are imported as new products and the relationships set up correctly?


If so, any tips/pointers on the order and fields to use? An export of products is not exactly clear, and we've seen varying results in testing imports. Thanks.



Re: Import configurable products in Magento 2


Here's my problem - see spreadsheet link above.  Not all columns are showing to get the picture - just the critical ones show in the picture - rest hidden. 


1)  I first created a configurable product along with the simple products from my magento 2.0 store - the drop downs worked perfectly and showed up in my store.  


2)  Then I exported the products to my desktop and deleted the products in my store as a test.


3)  I imported the same csv file back up to the store and now I cannot see the products in the store.


I think this is a bug in Magento 2.0 because it seems impossible to create configurable products from a csv file.  The only way to create working configurable products is from within the store itself which would take forever with thousands of products.  


BTW, simple products in a csv file can be imported and then seen in the store.  The documentation is super sparse on this critical subject - hopefully this will improve.  I have spent long days on this one problem and have tried many other experiments besides this one above.

Re: Import configurable products in Magento 2

We put together a tutorial on how to import configurable products into a Magento 2 store (after some trial and error). This method seems to work well:


Hopefully this helps with more complicated imports.

Re: Import configurable products in Magento 2

The  tutorial above, by Rob at Lexiconn, pointed out the need for the "configurable" product to be listed last in the CSV file which kind of surprised me but I'm sure makes sense somewhere in the coding. Regardless, the process did not work for me. It's a simple process, nothing overly complex once you get your head wrapped around those three key fields (attribute_set_code, additional_attributes and configurable_variations).

I hesitate to mention I've been working on this for several hours ... if it turns out to be something easy I'll be relieved but irritated. The fact that Rob at Lexiconn posted a tutorial for how to import configurable items makes me believe that it truly is possible.

The import works fine ... but after re-indexing and cleaning cache, I cannot see the product in my store. I have however, successfully created a configurable product that works just fine ... but there's one difference between the manual product and the imported product that I believe holds the key to my mystery. When the import completes, the configurable product, when viewed from the products catalog, is assigned one of the attributes (in my case, it's a clothing size like 28x32). When I look at the manually created product, the attribute field/box has no attribute set and is grayed out.

Re: Import configurable products in Magento 2

Well Well ... the problem was me ... obviously. I kept using the product "name" instead of the "sku" in the "configurable_variations" field ... sigh. Works like a charm now. Thanks Rob.

Re: Import configurable products in Magento 2

Glad to hear it worked well Donnie.  Smiley Happy

Re: Import configurable products in Magento 2

It's odd that I couldn't find any information on importing configurable products that have multiple attributes other than a vague blog entry.

I noticed that you cannot simply add a configurable product manually ... and then export the product database ... and expect to use that export as a complete and valid template for importing. The one field that seems to cause problems is the "configurable_variations" field. From an export, it appears that only one attribute is listed for each SKU (e.g., color) ... and then the "additional_attributes" field for each simple product would contain any other attributes (e.g., size). At least, that's the impression you get from an export. But an import will not work this way.

I've only been successful in these imports if I put every configurable attribute in the "configurable_variations" field of the configurable product (not the simple product).

I'm posting this message because I'm going to forget this next month and I'll need me to help me. Smiley Happy


Here's a link to the image in case this one is too small ...


Re: Import configurable products in Magento 2

how do i have to add the attributes like configurable variations etc. which settings do I use?

Re: Import configurable products in Magento 2

Importing with single attribute works. I am having issue in importing product with color and size attributes. Here are more details:

Re: Import configurable products in Magento 2

Hi, sorry for brining back to life this old post, but I'm banging my head against the wall for past 3 days with this. The best solution so far is noted by Donnie, he pointed out that configurable product must have the column "configurabe_variations" filled with all simple products with all attributes listed not just the last one. This is the crucial thing, Donnie thanks for that.


However the story is not over yet ;( the products are imported ok, can be seen in store frontend, can be bought, well they behave like they sholud, or at least it looks so Smiley Wink But the very important part is now missing, the "layered navigation". In case you have set you attributes (color, size, ...) to "Filterable (with results)", the user won't be able to filter anything, the "layered navigation" pane labeled by default "Shopping options" on the left side of the page (Luma theme), won't even display. On the flip side, if configurable products are made in backend manually "layered navigation" displays ok.


Has someone maybe faced this issue? I have cleared the cache and run reindexing manually after each retry. Any input is very welcome, thanks in advance.