cancel
Showing results for 
Search instead for 
Did you mean: 

Composer problem on updating module

SOLVED

Composer problem on updating module

Hi

 

I`m having a confusing issue after upgrading my store from 2.4.0 to 2.4.2, everything went as it should have except for every single extension from a specific vendor "Apptrian" refusing to update giving me the following error:

 

Error message:
Could not find a matching version of package apptrian/facebook-pixel.
Check the package spelling, your version constraint and that the package is available in a stability which matches your minimum-stability (dev).

 

I contacted the vendor and they confirm they are running this specific module on their own M2 2.4.2 store

 

I re-purchased the module under the Apptrian team suggestion as they speculated it could have been something related to the licence as I originally had the module as Free and it later became a 39.99$ but purchasing it didn`t fix the issue.

 

Could there be a bug related to Magento marketplace? 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Composer problem on updating module

I found the problem was the composer being version 1.x , upgrading to 2.x solved the issue

View solution in original post

1 REPLY 1

Re: Composer problem on updating module

I found the problem was the composer being version 1.x , upgrading to 2.x solved the issue

View solution in original post