cancel
Showing results for 
Search instead for 
Did you mean: 

Admin Panel & Home Pages Not loading properly

Highlighted

Admin Panel & Home Pages Not loading properly

I have tried a fresh restart of Magento 2.3.0 after the admin panel and home pages went to a menu type shown below. I shortened the Admin Menu for the example. Also using PHP 7.2

 

I thought I may have accidentally deleted a file while I was removing countries from the country menu to try and stop the massive spam attach by qq.com (china origin)

 

After removing and reinstalling the files I kept getting the same problem with the admin and home pages not loading properly. Clinking on the links only cycled me to the top of the page.

 

I loaded a copy of Magento 1.9.4 with no problems, Admin Panel and Home Page worked fine on 1.9.4

 

Admin Screen

Top of Form

  • Dashboard
  • Sales

Sales

o    Operations

  • Orders
  • Invoices
  • Shipments
  • Pickups
  • Dispatches
  • Batches
  • Credit Memos
  • Billing Agreements
  • Transactions
  • Catalog

Catalog

o    Inventory

  • Products
  • Categories
  • Customers

Customers

o    All Customers

o    Now Online

o    Customer Groups

  • Marketing

Marketing

o     

  • Promotions
  • Catalog Price Rule
  • Cart Price Rules
  • Communications
  • Email Templates
  • Newsletter Template
  • Newsletter Queue
  • Newsletter Subscribers

o     

  • SEO & Search
  • URL Rewrites
  • Search Terms
  • Search Synonyms
  • Site Map
  • User Content
  • Reviews
  • Marketing Automation
  • Automation Studio
  • Exclusion Rules
  • Content

Content

o    Elements

  • Pages
  • Blocks
  • Widgets

o    Design

  • Configuration
  • Themes
  • Schedule

 

Main Webpage Screen

Skip to Content

  •  
  • Sign In
  • Create an Account

Toggle Nav

My Cart

Search

Top of Form

Search

Advanced Search

Search

Bottom of Form

  • Compare Products

Menu

Account

Home Page

CMS homepage content goes here.

Newsletter

Top of Form

Sign Up for Our Newsletter:

Subscribe

Bottom of Form

  • Search Terms
  • Privacy and Cookie Policy
  • Orders and Returns
  • Advanced Search

Copyright © 2013-present Magento, Inc. All rights reserved.

 

 

9 REPLIES 9
Highlighted

Re: Admin Panel & Home Pages Not loading properly

Hello @Algrium 

 

Please clear cache as follows:

ROOT > var > cache > *DELETE ALL*
ROOT > var > page_cache > *DELETE ALL*
ROOT > var > session > *DELETE ALL*

also delete old files generated in ROOT > pub > static > DELETE ALL EXCEPT .HTACCESS

Now run below commands once:

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush
sudo chmod -R 0777 var/ pub/ generated/

It should work, try it.

Problem solved? Click Kudos & Accept as Solution!
Highlighted

Re: Admin Panel & Home Pages Not loading properly

Thank you. This solved the issue for me! 

Highlighted

Re: Admin Panel & Home Pages Not loading properly

Hi Manish, 

 

I was wondering if you could help me. 

 

After running through the advised steps i now recieve the following upon attempting to access my Magento Admin mage:

 

There has been an error processing your request

Exception printing is disabled by default for security reasons.

Error log record number: 1519827011273

 

Any ideas? I'm currently using this as a test server therefore am not concened about losing any customer data. Is there a quick fix or alternatively cleardown/rerun cmds you could advise?

Highlighted

Re: Admin Panel & Home Pages Not loading properly

Hi
Can you show me the content of error report 1519827011273?
You can get the file at magento/var/report/
1519827011273
Also provide me two files inside magento/var/log/ system.log and exception.log
So that I can check what error you are facing.
Highlighted

Re: Admin Panel

Swift response, thanks!

It says the following:

{"0":"Class Magento\\Backend\\Model\\Auth\\Session\\Interceptor does not exist","1":"

 

I've since tried rerunning the following installation steps:


Run below command to give permission:


cd /var/www/html/magento2 && find var vendor pub/static pub/media app/etc -type f -exec chmod g+w {} \; && find var vendor pub/static pub/media app/etc -type d -exec chmod g+w {} \; && chmod u+x bin/magento

However, upon executing the above I receive: 'changing permissions of 'bin/magento': Operation not permitted'

According to articles, this is because I executed chmod -R cmd previously?

Cheers,

Highlighted

Re: Admin Panel

Now working after executing the following:

 

chmod -R 0777 var/ pub/ generated/rm -rf var/cache/* pub/static/* generated/*
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy
php bin/magento indexer:reindex
php bin/magento cache:flush
chmod -R 0777 var/ pub/ generated/

 Source: https://community.magento.com/t5/Installing-Magento-2-x/An-error-has-happened-during-application-run...

Highlighted

Re: Admin Panel & Home Pages Not loading properly

I have the same issue. can you please explain me how to resolve the issue


@Manish Mittal wrote:

Hello @Algrium 

 

Please clear cache as follows:

ROOT > var > cache > *DELETE ALL*
ROOT > var > page_cache > *DELETE ALL*
ROOT > var > session > *DELETE ALL*

also delete old files generated in ROOT > pub > static > DELETE ALL EXCEPT .HTACCESS

Now run below commands once:

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush
sudo chmod -R 0777 var/ pub/ generated/

It should work, try it.


 

Highlighted

Re: Admin Panel & Home Pages Not loading properly

I am new and making my first website. So i don't know. Can you explain me please?


@awais_786 wrote:

I have the same issue. can you please explain me how to resolve the issue


@Manish Mittal wrote:

Hello @Algrium 

 

Please clear cache as follows:

ROOT > var > cache > *DELETE ALL*
ROOT > var > page_cache > *DELETE ALL*
ROOT > var > session > *DELETE ALL*

also delete old files generated in ROOT > pub > static > DELETE ALL EXCEPT .HTACCESS

Now run below commands once:

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush
sudo chmod -R 0777 var/ pub/ generated/

It should work, try it.


 



@awais_786 wrote:

I have the same issue. can you please explain me how to resolve the issue


@Manish Mittal wrote:

Hello @Algrium 

 

Please clear cache as follows:

ROOT > var > cache > *DELETE ALL*
ROOT > var > page_cache > *DELETE ALL*
ROOT > var > session > *DELETE ALL*

also delete old files generated in ROOT > pub > static > DELETE ALL EXCEPT .HTACCESS

Now run below commands once:

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush
sudo chmod -R 0777 var/ pub/ generated/

It should work, try it.


 


 

Highlighted

Re: Admin Panel & Home Pages Not loading properly

i have an same issue and i try your steps but it is not working

can you help me out

Sudhanshu