Showing results for 
Search instead for 
Did you mean: 

Configure Apache and Elasticsearch Magento2 CE (Version 2.4.0), Any advice?

Configure Apache and Elasticsearch Magento2 CE (Version 2.4.0), Any advice?

Ok, I found a post seems already answer my question, but still would like someone to confirm it.

From this post, we know that Magento2 CE, should use this elasticsuite, instead of Elasticsearch. Is my understanding correct ?

Now seem like I am almost finished installing Magento2 CE since now I am able reach the point of see "" page with Welcome message.

Not sure if I am not technical enough to follow this guide. I get stuck at step 6,
(Verify the proxy works by entering the following command, honestly, not even sure I got the all previous steps correct though)

My env. is GCP,
OS: Centos-release-8.2-2.2004.0.2.el8.x86_64

I believe that Elasticsearch is installed correctly since we can tell by

curl -X GET "localhost:9200/"
"name" : "testing",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "O4DAzmpwRVm8XCg",
"version" : {
"number" : "7.9.2",
"build_flavor" : "default",
"build_type" : "rpm",
"build_hash" : "d34da0ea4a966c4e49417f2da2f244e3e97b4e6e",
"build_date" : "2020-09-23T00:45:33.626720Z",
"build_snapshot" : false,
"lucene_version" : "8.6.2",
"minimum_wire_compatibility_version" : "6.8.0",
"minimum_index_compatibility_version" : "6.0.0-beta1"
"tagline" : "You Know, for Search"


sudo systemctl status elasticsearch
● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
Active: active (running)

When I run

curl -i http://localhost:8080/_cluster/health
[Fri Oct 9 13:36:56 2020] [::1]:39052 Accepted
[Fri Oct 9 13:36:56 2020] [::1]:39052 [404]: (null) /_cluster/health - No such file or directory
HTTP/1.1 404 Not Found
Host: localhost:8080
Date: Fri, 09 Oct 2020 13:36:56 GMT
Connection: close
Content-Type: text/html; charset=UTF-8
Content-Length: 548
This should be not the expected output?
However, when I run

curl -i http://localhost:9200/_cluster/health
HTTP/1.1 200 OK
content-type: application/json; charset=UTF-8
content-length: 389

Where is my directory structure.

[root@testing httpd]# ls
conf conf.d conf.modules.d logs modules run sites-available state

[root@testing sites-available]# ls
000-default.conf magento.conf

[root@testing sites-available]# cat 000-default.conf
Listen 8080
<VirtualHost *:8080>
ProxyPass "/" "https://localhost:9200/"
ProxyPassReverse "/" "https://localhost:9200/"


[root@testing sites-available]# cat magento.conf
<VirtualHost *:80>
DocumentRoot /var/www/html/magento/
<Directory /var/www/html/magento/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
ErrorLog /var/log/httpd/magento_error.log
CustomLog /var/log/httpd/magento_access.log combined