cancel
Showing results for 
Search instead for 
Did you mean: 

Error installing fresh download of 2.3.5

SOLVED

Error installing fresh download of 2.3.5

Hi there,

 

I recently installed a fresh version of PHP7.4 to my computer so that I could use the latest Magento 2.3.5 for a new store. Fresh .zip download.

 

After having to trawl through very strangely laid out documentation to work out the correct command line command to use to install with database details (not clear, you really have to dig) but I got the following error

 

[Progress: 263 / 992]
Module 'Magento_Amqp':

In ErrorHandler.php line 61:

Deprecated Functionality: Function ReflectionType::__toString() is deprecat
ed in /var/www/puppypridestore-2.3.5/vendor/laminas/laminas-code/src/Reflec
tion/ParameterReflection.php on line 83

 

 

Any idea whats wrong?

 

PHP 7.4.6 (cli) (built: May 14 2020 10:02:44) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
with Zend OPcache v7.4.6, Copyright (c), by Zend Technologies

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error installing fresh download of 2.3.5

Hi @kye_etherton 

Yes, 2.4.x still in beta not stable.

I will recommend stable release 2.3.5-p1 for now.

So you can downgrade your php to 7.3.

View solution in original post

10 REPLIES 10

Re: Error installing fresh download of 2.3.5

Hi @kye_etherton 

Magento 2.3.x doesn't support PHP 7.4. You ca try with 7.3 if using 2.3.x.

https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

Magento 2.4.x supports PHP 7.4.

https://devdocs.magento.com/guides/v2.4/install-gde/system-requirements-tech.html

I hope it will help you!

Re: Error installing fresh download of 2.3.5

Hi there,

 

On the downloads page: https://magento.com/tech-resources/download there's not 2.4, but the docs said to use PHP7.4.

 

Whats the best version of Magento to download, and where would I get it?

Re: Error installing fresh download of 2.3.5

@kye_etherton 

 

Magento not released yet Magento 2.4, only beta version they have released. You can download for now only ver 2.3.5-p1. 

Manish Mittal
https://www.manishmittal.com/

Re: Error installing fresh download of 2.3.5

Hi @kye_etherton 

Yes, 2.4.x still in beta not stable.

I will recommend stable release 2.3.5-p1 for now.

So you can downgrade your php to 7.3.

View solution in original post

Re: Error installing fresh download of 2.3.5

That's REALLY bad for the installation documentation to have the wrong version of PHP listed on it then...

Re: Error installing fresh download of 2.3.5

Is there a command list apt-get line for PHP7.3 with all required mods?

Re: Error installing fresh download of 2.3.5

@kye_etherton 

 

Can you share where it is mentioned to use PHP 7.4 with Magento 2.3.x?

 

 

https://devdocs.magento.com/guides/v2.3/install-gde/prereq/php-settings.html

Manish Mittal
https://www.manishmittal.com/

Re: Error installing fresh download of 2.3.5

Hi @kye_etherton 

I think you have read the wrong blog or page.

Can you please share the link if your find PHP 7.4 for Magento 2.3.x?

Re: Error installing fresh download of 2.3.5

I just clicked on installation guides and it took to me one that said PHP7.4 on it, It's been a long two days and I'm not sure where it was