cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 - Localhost - Admin url returning 404

Re: Magento 2 - Localhost - Admin url returning 404

In my case i has to enable the apache's mod_rewrite

 

sudo a2enmod rewrite

 

Re: Magento 2 - Localhost - Admin url returning 404

The error occurs because of .htaccess file on your Magento 2 installation folder. Htaccess file is missing or wrong setting make Magento 2.

If you’re using Nginx, the rewrite part of Nginx conf file may be missing or not working.

Temporarily solution

You can gain access to website by putting “index.php” in the url like this example: yourwebsite.com/index.php or for admin access: /magento2/index.php/admin

Refer this tutorial to see if you are missing any step

https://magentip.com/install-magento-2-on-localhost-xampp-elasticsearch/

 

Hope this helps!

Re: Magento 2 - Localhost - Admin url returning 404

i am still getting 404 not found error

Re: Magento 2 - Localhost - Admin url returning 404

@jack_sparrows  Do you remember how you get the solution?

Re: Magento 2 - Localhost - Admin url returning 404

excelente me funciono con eso

Re: Magento 2 - Localhost - Admin url returning 404

Thank you for your question. I have learned your comments here

 

Friv 9

 

 

Re: Magento 2 - Localhost - Admin url returning 404

Where I get this page "apache2.conf".


@Mukesh Tiwari wrote:

Edit apache2.conf file and change following

 

<Directory /var/www/>
     Options Indexes FollowSymLinks
     AllowOverride None
     Require all granted
</Directory>

to

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

 

Re: Magento 2 - Localhost - Admin url returning 404

Hello @arrahtakgm202c 

 

if frontend is working fine then please check in core_config_data table. there should be different admin url mention.

 

If my answer is useful, please Accept as Solution & give Kudos

Re: Magento 2 - Localhost - Admin url returning 404

I am using ubuntu 18.04.running the Magento in a virtual host locally.

my admin URL not working I checked the URL it has HTTPS.

so i changed core_config_data -> web/secure/base_url -> HTTP.

after clear the cache, it's working.