cancel
Showing results for 
Search instead for 
Did you mean: 

after installation i am facing some issue "Whoops, our bad..."

after installation i am facing some issue "Whoops, our bad..."

hi

 

i was following the instruction guideline mentioned in the documentation 

OS:

Linux ip-172-31-10-164 5.4.0-1048-aws #50-Ubuntu SMP Mon May 3 21:44:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

after this, I tried to replace .htaccess but did not work.

DB:

AWS RDS MYSQL 

setup command :

bin/magento setup:install \
--use-secure=1 \
--base-url-secure=https://zoqolo.com/somecustompath \
--use-secure-admin=1 \
--base-url=https://zoqolo.com/basepath \
--db-host=xxxxxxsome.rds.amazonaws.com \
--db-name=xxxxxxxxxx \
--db-user=xxxxxxuser \
--db-password=xxxxxxxxxxxsomepasss \
--db-prefix=some5charecter_ \
--admin-firstname=customfirstname \
--admin-lastname=xxxxxxxx \
--admin-email=xxxxxxxx@somedomain.com \
--admin-user=xxxxxxxxxx \
--admin-password=somepassword \
--language=en_US \
--currency=INR \
--backend-frontname=custom_name \
--timezone=Asia/Kolkata \
--use-rewrites=1 \
--search-engine=elasticsearch7 \
--elasticsearch-host=localhost \
--elasticsearch-port=9200

it was an installation with SSL. CE latest with localhost elastic search.

so how to fix it?  

 

Nb: I tried :

$ php bin/magento cache:clean
Cleaned cache types:
config
layout
block_html
collections
reflection
db_ddl
compiled_config
eav
customer_notification
config_integration
config_integration_api
full_page
config_webservice
translate
vertex


$ rm -rf generated/*
rm: cannot remove 'generated/code/Magento': Directory not empty
$ php bin/magento deploy:mode:show
Current application mode: default. (Note: Environment variables may override this value.)
$ rm -rf var/cache/*
$ rm -rf var/generation/*
$ php bin/magento deploy:mode:set production

no luck. 

 

thx

 

 

2 REPLIES 2

Re: after installation i am facing some issue "Whoops, our bad..."

It looks like you still have Magento installed in your website root and as such you might want to consider removing that first before trying to install a second copy.

cheatengine

Re: after installation i am facing some issue "Whoops, our bad..."

there were no magento installed as a first copy my document root pointing perfectly towards the urls "somecustompath." i tried to install clouflare so i did but it failed to create tables in databases 

composer require cloudflare/cloudflare-magento
composer update
Package container-interop/container-interop is abandoned, you should avoid using it. Use psr/container instead.
Package laminas/laminas-console is abandoned, you should avoid using it. Use laminas/laminas-cli instead.
Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
Package sebastian/finder-facade is abandoned, you should avoid using it. No replacement was suggested.