cancel
Showing results for 
Search instead for 
Did you mean: 

cannot see LUMA home page

cannot see LUMA home page

i !

I correctly installed magento 2 locally (v2.3.7) on windows 10,
no error. The database is also correct.
But the LUMA theme home page is not showing.
I still have this page :
https://goopics.net/i/NqyjZ

or that (base-url = http: //127.0.0.1/magento2/) :

https://goopics.net/i/kGNAo
All link of this page shows 404

I don't understand why, I made a composer update, a clear cache etc ...
Nothing, always the same.

If someone has an idea.
Thank you in advance Smiley Happy

6 REPLIES 6

Re: cannot see LUMA home page

Hello @Tsumiko 

 

Can you upload the screenshot here as the link you have shared its not showcasing the screenshot I think its removed so.

 

Or post the error which showcasing on the screen, so its help us to troubleshoot the issue.

 

Thanks

if issue solved,Click Kudos & Accept as Solution

Re: cannot see LUMA home page

Hi
Thx
The links are good now Smiley Happy

Re: cannot see LUMA home page

Hello @Tsumiko 

 

As you are installing Magento 2.3.7, so you need to point out your pub directory as a root directory of the Magento in your apache or nginx server.

 

Refer this link for the same - https://devdocs.magento.com/guides/v2.4/install-gde/tutorials/change-docroot-to-pub.html

 

After that run the following commands from command line : 

  • php bin/magento setup:upgrade
  • php bin/magento setup:di:compile
  • php bin/magento setup:static-content:deploy
  • php bin/magento cache:clean
  • php bin/magento cache:flush

It will resolve your problem.

if issue solved,Click Kudos & Accept as Solution

Re: cannot see LUMA home page

Hello @Tsumiko 

 

You have to apply changes in your root directory.

 

Copy the index.php and .htaccess files from the pub folder and paste them into the root directory.

 

Refer to the https://meetanshi.com/blog/install-magento-2-4-2-on-localhost-using-xampp/ for the required solution.

 

If you've already installed Magento 2.3.7 then skip the installation steps from the above blog and refer to other solutions mentioned in the post.

 

I hope it helps.
Problem solved? Click Kudos and "Accept as Solution"

Re: cannot see LUMA home page

Thank you both, Manthan Dave and Sanjay Jethva, for your help, but I removed version 2.3.7, it was the demo version, so incomplete.

And so I am installing version 2.4.2 p1 with datas

Strange thing:
When install elastisearch (.\Bin\elasticsearch.bat)
The installation stops at this line:
([2021-05-20T17: 28: 34,291] [INFO] [o.e.g.GatewayService] [TOUTIMOUNT] recovered [0] indices into cluster_state)
It can stay that way for hours and when I type http: // localhost: 9200, the information is displayed correctly.
If I close the command window, the http: // localhost: 9200 page displays "localhost refused the connection."
???

When I run the php bin / magento setup command: install --base-url = http: // localhost / magento2 / --db-host = localhost --db-name = magento2 --db-user = root --db -password = --admin-firstname = admin --admin-lastname = admin --admin-email=mymail@mail.fr --admin-user = admin --admin-password = admin123 --language = fr_FR --currency = EUR --timezone = Europe / Paris --use-rewrites = 1 --backend-frontname = admin --search-engine = elasticsearch7 --elasticsearch-host = localhost --elasticsearch-port = 9200

I have the message:
"Could not validate a connection to Elasticsearch. No alive nodes found in your cluster"

In the database, the "core_config_data" table does have the correct data.

My virtual host :

<VirtualHost *: 80>

DocumentRoot "D: \ xamp \ htdocs \ magento2 \ pub"
SetEnv APPLICATION_ENV "development"
<Directory "D: \ xamp \ htdocs \ magento2 \ pub">
DirectoryIndex index.php
AllowOverride All
Order allow, deny
Allow from all
</Directory>

</VirtualHost>

I followed this tutorial:
https://www.simicart.com/blog/how-to-install-magento-2-localhost/

I cannot inderstand why the installation is so diffucult often folling the tuto

Thx for your help

Re: cannot see LUMA home page

I deleted everything and did a reinstall, and everything is working fine now