cancel
Showing results for 
Search instead for 
Did you mean: 

Static blocs not showing in added language

SOLVED
Highlighted

Re: Static blocs not showing in added language

Yes. 

Is the block with ID 4 set to be displayed in both stores?

Highlighted

Re: Static blocs not showing in added language

This is the list of blocks: https://lucvos.be/blocks.png

 

As far as I can see, all necessary blocks are shown where they should, or aren't they?

 

thanks!

 

Best regards

 

luc 

Highlighted

Re: Static blocs not showing in added language

I believe you are not seeing this block here. It is set to English only. If this is it, can you edit it and also set the abc store?

 

https://i.imgur.com/SxFRV7N.png

Highlighted

Re: Static blocs not showing in added language

I don't think I understand. The showcase is set to English. What block do you mean?

 

And what do you mean with abc store?

 

thanks!

 

best regards

 

luc 

Highlighted

Re: Static blocs not showing in added language

Hi @luclucvosbd4e0 ,

 

We believe you are using Block with identifier 'showcase' (Block Id: 4) on the homepage. Please correct me if this is wrong.

 

Now, in your site, we have 2 store views (English, Netherlands). Now the above block(Block Id: 4) is set to use only in the English store view. Please assign this block to the other store view as well or you can use all store view option,

 

Save the block and refresh your Magento cache. 

 

Thanks!

Problem Solved! Click Kudos & Accept as Solution.

Highlighted

Re: Static blocs not showing in added language

thanks for your feedback, but I think it is set correctly.

 

See: https://lucvos.be/showcase%20blocks.png

 

There is a showcase in both English & Netherlands, but it is not showing. What could be wrong?

 

thanks!

 

best regards

 

luc 

Highlighted

Re: Static blocs not showing in added language

Hi @luclucvosbd4e0 ,

I am considering you have same homepage for both the stores. If not then please add same code in the respective store view homepage. 

 

Add the same code in the content section of homepage which is highlighted in the screenshot. Please change the Id of the block with the new Id which is assigned to netherland store. 

Example :

English store : block Id 

Thanks!

Problem Solved! Click kudos & Accept as Solution!

View solution in original post

Highlighted

Re: Static blocs not showing in added language

That did it! Thanks very much for your help!

 

Best regards

 

luc