cancel
Showing results for 
Search instead for 
Did you mean: 

Patch SUPEE-11155 on Magento CE 1.7.0.2

SOLVED
Highlighted

Patch SUPEE-11155 on Magento CE 1.7.0.2

I tried to install the patch SUPEE-11155 on Magento CE 1.7.0.2 and it fails because it cannot find the below file:

 

 

/app/code/core/Mage/Catalog/Model/Product/Option/Type/File.php.orig

 

From the file extension (.orig) I presume it is not a functional PHP file. Most probably it was included in a previous patch. Although I have installed all previous patches, this file is not found in my Magento CE 1.7.0.2 installation.

 

Does anybody know how has the file File.php.orig, required by SUPEE-11155, come into place?

 

On the other hand, I read at some other forum that the SUPEE-11155 can be modified in a way that the lines related with the file File.php.orig are removed, but I'm not sure about other complications that may occur due to such a modification.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Patch SUPEE-11155 on Magento CE 1.7.0.2

Hello @dandrikop 

It shows this file code need to be removed.
http://prntscr.com/pvvuqr

Looking at patch file it seems it needs all the codes need to be removed starting from notice.

So i believe, that patch removes the complete code inside of that file. http://prntscr.com/pvvx47

This should be the last code in that file.

Suggestion

I would advise its always better to get your Magento version upgraded to the latest for now which includes all the security patches.

You can take help of any Magento agency or hire any Magento developer to get it done smoothly.

Found something useful, "Kudos" and "Accept as Solution" for Token of Appreciation.

Magento Tutorials

View solution in original post

2 REPLIES 2
Highlighted

Re: Patch SUPEE-11155 on Magento CE 1.7.0.2

Hi @dandrikop 

 

As you have read just remove lines from 874 - 1702 (referring to File.php.orig) from the patch script.

 

You have to remove the code from line no. 874 to line no. 1702.

 

Hope it helps you!

 

Thanks

---
If you've found my answer useful, please give"Kudos" and "Accept as Solution".

Highlighted

Re: Patch SUPEE-11155 on Magento CE 1.7.0.2

Hello @dandrikop 

It shows this file code need to be removed.
http://prntscr.com/pvvuqr

Looking at patch file it seems it needs all the codes need to be removed starting from notice.

So i believe, that patch removes the complete code inside of that file. http://prntscr.com/pvvx47

This should be the last code in that file.

Suggestion

I would advise its always better to get your Magento version upgraded to the latest for now which includes all the security patches.

You can take help of any Magento agency or hire any Magento developer to get it done smoothly.

Found something useful, "Kudos" and "Accept as Solution" for Token of Appreciation.

Magento Tutorials

View solution in original post