cancel
Showing results for 
Search instead for 
Did you mean: 

SUPEE-11155 Failed on Magento 1.9.0.1 CE

SOLVED

SUPEE-11155 Failed on Magento 1.9.0.1 CE

Hello - trying to patch a Magento 1.9.0.1 CE site with v4 of SUPEE-11155 but get the following errors:

 

checking file app/Mage.php
Hunk #1 FAILED at 813.

....

checking file app/code/core/Mage/Cms/Helper/Data.php
Hunk #1 FAILED at 37.

....

 

Any thoughts on a way around?

 

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: SUPEE-11155 Failed on Magento 1.9.0.1 CE

Hello @Jonathon Harris 
According to https://magecomp.com/blog/how-to-install-magento-security-patches/

There are some space or line issues while updating the patch.
For example,

It has been set that at this line, a particular code needs to be changed, if the patch doesn’t find the code at the specified line it throws this error.

 

Every code line had a CRLF line (empty line) under it. This could be the reason for this error. You will need to find the file and remove these lines between code from files. In short file needs to match exactly what Magento has in its repository for the patch to apply.

 

My Recommendation,

Go ahead and upgrade your Magento version to the latest Magento 1.9.4.3 which includes all the security patches. You can contact any Magento Agency or developer if you don't know how to.

Found something useful, "Kudos" and "Accept as Solution" for Token of Appreciation.

Magento Tutorials

View solution in original post

1 REPLY 1
Highlighted

Re: SUPEE-11155 Failed on Magento 1.9.0.1 CE

Hello @Jonathon Harris 
According to https://magecomp.com/blog/how-to-install-magento-security-patches/

There are some space or line issues while updating the patch.
For example,

It has been set that at this line, a particular code needs to be changed, if the patch doesn’t find the code at the specified line it throws this error.

 

Every code line had a CRLF line (empty line) under it. This could be the reason for this error. You will need to find the file and remove these lines between code from files. In short file needs to match exactly what Magento has in its repository for the patch to apply.

 

My Recommendation,

Go ahead and upgrade your Magento version to the latest Magento 1.9.4.3 which includes all the security patches. You can contact any Magento Agency or developer if you don't know how to.

Found something useful, "Kudos" and "Accept as Solution" for Token of Appreciation.

Magento Tutorials

View solution in original post