cancel
Showing results for 
Search instead for 
Did you mean: 

1.9.4.1 upgrade failed due to PHP 7.2 & deleted files

Highlighted

1.9.4.1 upgrade failed due to PHP 7.2 & deleted files

Today, I tried updating from 1.9.4.0 to 1.9.4.1, and the update process gave the following error: "requires PHP version >= 5.2.0 and <= 6.0.0" despite the fact that Magento started supporting PHP 7.2 with version 1.9.4.0.  It also deleted thousands of files, necessitating a restore from a backup.  Has anyone else experienced either of these problems?

4 REPLIES 4
Highlighted

Re: 1.9.4.1 upgrade failed due to PHP 7.2 & deleted files

Yep faced the same problem when upgraded from 1.9.3.10 to 1.9.4.0. Had to change PHP version to 5.6.3 for my store (via CPanel), upgrade and then change back to PHP7x

Highlighted

Re: 1.9.4.1 upgrade failed due to PHP 7.2 & deleted files

How did you do the upgrade when the files are delete?

Highlighted

Re: 1.9.4.1 upgrade failed due to PHP 7.2 & deleted files

I have not updated my Magento store

Highlighted

Re: 1.9.4.1 upgrade failed due to PHP 7.2 & deleted files

You can perform the upgrade in command line with PHP 5.6.

How to do this?: change the setting of your server to run PHP 5.6 in CLI and 7.2 in web server, it will not affect your website, check the detail here: https://secure.php.net/manual/en/install.general.php.

After that, you can upgrade your Magento store without problems.

 

Another solution (not recommended):

Copy entire your Magento 1.9.4.0 to another server with PHP 5.6 running, then perform the upgrade. After it's upgraded successfully, copy the source code back to your PHP 7.2 server.

Magento migration service. Cheapest. Fastest. Easiest.