cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to run v1.9.4.2 upgrade on PHP 7.2 Server

Highlighted

Unable to run v1.9.4.2 upgrade on PHP 7.2 Server

All of the Magento installs we look after are now running v1.9.4.1 on PHP 7.2 servers.

 

With the release of v1.9.4.2 it is not possible to upgrade to it as the install fails.

 

Running the upgrade from the downloader line you get this:

CONNECT ERROR: Package community/Mage_All_Latest 1.9.4.2: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.15

 

Why is a PHP 7.2 compatible package tagged as requiring <= PHP 6.0.0???

 

There was the same issue with the previous update package to v1.9.4.1!

2 REPLIES 2
Highlighted

Re: Unable to run v1.9.4.2 upgrade on PHP 7.2 Server

Hi @SteamDesk 

Are you upgrading using terminal?

I will suggest to upgrade using terminal. 

You can use steps mentioned in the following blog "Upgrade Magento 1.x via Command Line" ::

upgrade-magento-1-x-to-latest-version-via-command-line

I hope it will help you!

----
Problem solved? Click Accept as Solution!
Highlighted

Re: Unable to run v1.9.4.2 upgrade on PHP 7.2 Server

@Vimal Kumar  We did try that, it doesn't work from the command line or the web interface when you are using PHP 7.2