cancel
Showing results for 
Search instead for 
Did you mean: 

Admin url

Highlighted

Admin url

I have a site ready 

call lankadirect.com.au 
whenever I access the Magento admin panel it shows it like this 
Screenshot_18.jpg

(Lankadirect.com.au/admin instead of this it shows it like this lankadirect.com.auadmin

Please help

4 REPLIES 4
Highlighted

Re: Admin url

Hi @yohanramec2e12 

 

Please check admin_url with in core_config_data table first:
admin_url.png

 

If admin url is set with table then verify with app/etc/env.php file

return [
    'backend' => [
        'frontName' => 'admin'
    ],

If backend value is set with this file then flush cache and try with url as below:
http://127.0.01/xyz_magento/admin

This is only configuration to set path of admin.

 

It may help you!
Problem solved? Please click on 'Kudos' & Accept as Solution!


Highlighted

Re: Admin url

Screenshot_19.jpgScreenshot_20.jpg

 

This is my DB 

and ENV.PHP files 

everything seems to be alright! 
But the /admin is still the same!

Highlighted

Re: Admin url

Screenshot_19.jpgScreenshot_20.jpg

Highlighted

Re: Admin url

Hello @yohanramec2e12 

 

Make sure you are not using Custom Admin URL, you can disable it here in admin :

Store > Configuration > Advanced > Admin > Admin Base URL

Set it to NO, and enable Custom Admin Path where value should be only "admin" (if you want admin name as "admin").

 

if still doesn't work, check if your base URL has "/" in end, you can get the Base URL from command line also :

php bin/magento config:show web/secure/base_url
php bin/magento config:set web/unsecure/base_url

Make sure both result should have an end "/".

 

Hope it helps !

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !