cancel
Showing results for 
Search instead for 
Did you mean: 

Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

Highlighted

Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

Since i upgraded from Magento 2.2.7 to Magento 2.3.1 i am getting this message in the system.log file:

 

main.INFO: Consumer "async.operations.all" skipped as required connection "amqp" is not configured. Unknown connection name amqp [] []

 

i get this error also on a fresh Magento 2.3.1 install.

 

where in the settings this can be configured?

16 REPLIES 16
Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

Hello @RaFr 

 

Can you please check and confirm that cron is running or not ?

 

You will require start/run your cron for the same.

 

Refer this link for more details - https://community.magento.com/t5/Magento-2-x-Technical-Issues/Whoops-our-bad-error-on-main-store-pag...

 

They do have enable the cron and it resolved their issue so it might help you in this case.

 

Hope it helps !

if issue solved,Click Kudos & Accept as Solution
Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

 


@Manthan Dave wrote:

Hello @RaFr 

 

Can you please check and confirm that cron is running or not ?

 

You will require start/run your cron for the same.

 

Refer this link for more details - https://community.magento.com/t5/Magento-2-x-Technical-Issues/Whoops-our-bad-error-on-main-store-pag...

 

They do have enable the cron and it resolved their issue so it might help you in this case.

 

Hope it helps !


Hello @Manthan Dave 
The cron is running and on one of the installations it was removed and reinstalled but nothing changed.

i put the code below in the env.php file yesterday. i didn't have any entry on "'async.operations.all" in the system.log file since then, and everything else seems still working for now. but i can't confirm the solution for others

'cron_consumers_runner' => array(
        'cron_run' => false,
        'max_messages' => 1000,
        'consumers' => array(
            'async.operations.all',
        )
    )

i read everywhere that the message queue connection can be switched form amqp to db (database), but they don't explain how to do that without editing the core files, and it doesn't seem to be related to any of the 3rd party applications i am using.

Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

Hello, i am having the same issue. Can you please explain which env.php are you talking about? The one in app/etc? Where should i insert the code, top, center or bottom of file?

 

Thank you.

Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

file location:

magento2/app/etc/env.php

add code between return [];

 

<?php
return [

 ],       //<----------On a new line after the existing code do not forget to add comma


'cron_consumers_runner' => array(
'cron_run' => false,
'max_messages' => 1000,
'consumers' => array(
'async.operations.all',
)
)

]; // return closing

 

Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.


@theonlytoshka wrote:

Hello, i am having the same issue. Can you please explain which env.php are you talking about? The one in app/etc? Where should i insert the code, top, center or bottom of file?

 

Thank you.



sorry @theonlytoshka i didn't see your questions until now. i didn't receive a notification .... the answers are in the previous post 

Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

Works like a charm! Waited a couple of days before posting a reply. Thank you.

Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

php bin/magento disable:module Magento_Amqp

 

It seems easier ;-)

 

Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

When I try this, I get this response: There are no commands defined in the "disable" namespace.

Highlighted

Re: Consumer “async.operations.all” skipped as required connection “amqp” is not configured.

Because it's supposed to be module:disable not disable:module