cancel
Showing results for 
Search instead for 
Did you mean: 

Internal error: Make sure you are using reCaptcha V3 api keys

SOLVED

Internal error: Make sure you are using reCaptcha V3 api keys

Can't log in because of this. I just upgraded to 2.3.4. I thought I was using V2. the sub-domain is listed in recahtcha. The root is fine.

I deleted var/cache

I disable it google recaptha in the database

Now I can not get pass "There has been an error processing your request"

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Internal error: Make sure you are using reCaptcha V3 api keys

Fixed it

It was because the Dotdigitalgroup_Email was disabled

View solution in original post

8 REPLIES 8

Re: Internal error: Make sure you are using reCaptcha V3 api keys

@Mrferguson please check the var/logs.

 

There you will find the error.

Please share the error here.

Re: Internal error: Make sure you are using reCaptcha V3 api keys

Here is the error

[2020-02-04 01:40:52] main.CRITICAL: Specified invalid parent id (Dotdigitalgroup_Email::marketing_automation) {"report_id":"34be7144480ba536d83f1924dd003c817872b6356100a1a3c6c50006dc0f2a6c","exception":"[object] (OutOfRangeException(code: 0): Specified invalid parent id (Dotdigitalgroup_Email::marketing_automation)

 

 

{"0":"Specified invalid parent id (Dotdigitalgroup_Email::marketing_automation)","1":"#1 Magento\\Backend\\Model\\Menu\\Builder\\Interceptor->___callParent() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:138]\n#2 Magento\\Backend\\Model\\Menu\\Builder\\Interceptor->Magento\\Framework\\Interception\\{closure}() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:153]\n#3 Magento\\Backend\\Model\\Menu\\Builder\\Interceptor->___callPlugins() called at [generated\/code\/Magento\/Backend\/Model\/Menu\/Builder\/Interceptor.php:26]\n#4 Magento\\Backend\\Model\\Menu\\Builder\\Interceptor->getResult() called at [vendor\/magento\/module-backend\/Model\/Menu\/Config.php:148]\n#5 Magento\\Backend\\Model\\Menu\\Config->_initMenu() called at [vendor\/magento\/module-backend\/Model\/Menu\/Config.php:111]\n#6 Magento\\Backend\\Model\\Menu\\Config->getMenu() called at [vendor\/magento\/module-backend\/Model\/Url.php:365]\n#7 Magento\\Backend\\Model\\Url->_getMenu() called at [vendor\/magento\/module-backend\/Model\/Url.php:325]\n#8 Magento\\Backend\\Model\\Url->getStartupPageUrl() called at [vendor\/magento\/module-backend\/Controller\/Adminhtml\/Index\/Index.php:24]\n#9 Magento\\Backend\\Controller\\Adminhtml\\Index\\Index->execute() called at [vendor\/magento\/framework\/App\/Action\/Action.php:108]\n#10 Magento\\Framework\\App\\Action\\Action->dispatch() called at [vendor\/magento\/module-backend\/App\/AbstractAction.php:231]\n#11 Magento\\Backend\\App\\AbstractAction->dispatch() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:58]\n#12 Magento\\Backend\\Controller\\Adminhtml\\Index\\Index\\Interceptor->___callParent() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:138]\n#13 Magento\\Backend\\Controller\\Adminhtml\\Index\\Index\\Interceptor->Magento\\Framework\\Interception\\{closure}() called at [vendor\/magento\/module-backend\/App\/Action\/Plugin\/Authentication.php:143]\n#14 Magento\\Backend\\App\\Action\\Plugin\\Authentication->aroundDispatch() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:135]\n#15 Magento\\Backend\\Controller\\Adminhtml\\Index\\Index\\Interceptor->Magento\\Framework\\Interception\\{closure}() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:153]\n#16 Magento\\Backend\\Controller\\Adminhtml\\Index\\Index\\Interceptor->___callPlugins() called at [generated\/code\/Magento\/Backend\/Controller\/Adminhtml\/Index\/Index\/Interceptor.php:26]\n#17 Magento\\Backend\\Controller\\Adminhtml\\Index\\Index\\Interceptor->dispatch() called at [vendor\/magento\/framework\/App\/FrontController.php:159]\n#18 Magento\\Framework\\App\\FrontController->processRequest() called at [vendor\/magento\/framework\/App\/FrontController.php:99]\n#19 Magento\\Framework\\App\\FrontController->dispatch() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:58]\n#20 Magento\\Framework\\App\\FrontController\\Interceptor->___callParent() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:138]\n#21 Magento\\Framework\\App\\FrontController\\Interceptor->Magento\\Framework\\Interception\\{closure}() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:153]\n#22 Magento\\Framework\\App\\FrontController\\Interceptor->___callPlugins() called at [generated\/code\/Magento\/Framework\/App\/FrontController\/Interceptor.php:26]\n#23 Magento\\Framework\\App\\FrontController\\Interceptor->dispatch() called at [vendor\/magento\/framework\/App\/Http.php:116]\n#24 Magento\\Framework\\App\\Http->launch() called at [vendor\/magento\/framework\/App\/Bootstrap.php:261]\n#25 Magento\\Framework\\App\\Bootstrap->run() called at [index.php:39]\n","url":"\/admin_9ougs5\/admin\/index

Re: Internal error: Make sure you are using reCaptcha V3 api keys

Fixed it

It was because the Dotdigitalgroup_Email was disabled

View solution in original post

Re: Internal error: Make sure you are using reCaptcha V3 api keys

@Mrferguson Good to hear this.

Please mark it as solution so if anyone facing the same issue will easily reach out to this.

 

Thanks

Re: Internal error: Make sure you are using reCaptcha V3 api keys

I updated to 2.3.4 today - I am getting the same error, but it doesnt appear to be logging to var.

 

I was using recaptcha v2 prior to the update, so no - I wouldnt be using v3 keys. I will try to replace v2 keys with v3 keys in the database to see if this will correct the issue, but at the moment, this is clearly a bug.

 

** I replaced the old v2 keys with v3 keys directly in the database, and this DID fix the issue **

Steps to fix;

 

Update Keys Located in

 core_config_data/msp_securitysuite_recaptcha/general/public_key

 core_config_data/msp_securitysuite_recaptcha/general/private_key

 

Refresh Caches

First login failed with 'incorrect captcha'

Second Login worked.

 

And thats it!

 

Good luck out there!

 

Re: Internal error: Make sure you are using reCaptcha V3 api keys

Magento 2.3.4 automatically activate reCaptcha v3. Juste change to reCaptcha v2 in Store>Configuration>Security>Google reCaptcha.

Re: Internal error: Make sure you are using reCaptcha V3 api keys

Can you clarify which configuration setting needs to be changed to enable the Dotdigitalgroup email? I'm getting a similar error but your solution isn't very clear.

Re: Internal error: Make sure you are using reCaptcha V3 api keys

There are some configurations that need to be noticed here:

1. Dotdigital_Email: it should be enabled in config.php if you use it.

2. In my case: MSP_ReCaptcha uses Recaptcha v3 but Magento_captcha still enabled v2. You can disable it here: Store > Configuration > CAPTCHA > Enable CAPTCHA on Storefront

Beside there is another configuration of Magento_Captcha for Admin: Store > Advance > Admin > CAPTCHA