cancel
Showing results for 
Search instead for 
Did you mean: 

magento version 2.3. Admin login showing this error. how can i solve it?

Highlighted

magento version 2.3. Admin login showing this error. how can i solve it?

1 exception(s):
Exception #0 (Exception): Notice: Undefined offset: 2 in /home/309544.cloudwaysapps.com/gusczrhbaj/public_html/vendor/magento/framework/Encryption/Encryptor.php on line 588

Exception #0 (Exception): Notice: Undefined offset: 2 in /home/309544.cloudwaysapps.com/gusczrhbaj/public_html/vendor/magento/framework/Encryption/Encryptor.php on line 588
7 REPLIES 7
Highlighted

Re: magento version 2.3. Admin login showing this error. how can i solve it?

Re: magento version 2.3. Admin login showing this error. how can i solve it?

Has anyone found a solution that does not involve the workaround proposed that updates the admin_user record with:

 

UPDATE admin_user SET password = CONCAT(SHA2('xxxxxxxxNewPassword', 256), ':xxxxxxxx:1') WHERE username = 'username';

?

 
I am running a local dev environment on Vagrant, Ubuntu, PHP 7.3.9, which comes with Sodium built-in and enabled. Also, running MySQL 5.7.27. 
 
Any ideas are appreciated. 
Highlighted

Re: magento version 2.3. Admin login showing this error. how can i solve it?

magento 2.3.3 required php 7.2 you must be using php 7.1 try updating php version.
Highlighted

Re: magento version 2.3. Admin login showing this error. how can i solve it?

Highlighted

Re: magento version 2.3. Admin login showing this error. how can i solve it?

Please follow the below to resolve this

For this you have to check you php version which you use for magento version 2.3

you can check magento 2.3 requirements here : https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

 

Let me know if any issues

 

If my answer is useful, please Accept as Solution & give Kudos

 

Thank you

Aims Infosoft

Highlighted

Re: magento version 2.3. Admin login showing this error. how can i solve it?

Hey!

Just simply update your PHP version because Magento 2 won't work on 7.1. 

If you still need any help, feel free to ping me or inbox me.


Highlighted

Re: magento version 2.3. Admin login showing this error. how can i solve it?

this error coming on magento 2.4 with php 7.4