cancel
Showing results for 
Search instead for 
Did you mean: 

Elasticsearch version for 2.4

Elasticsearch version for 2.4

Planning to upgrade to 2.4 and I was wondering will Magento work on Elasticsearch 7.8 or is it better to go to 7.0?

Anyone tested this yet?

6 REPLIES 6

Re: Elasticsearch version for 2.4

Magento 2.4 officially supports Elasticsearch 7.6.x but should work with 7.8.x as well.

 

If you are risk averse, you can go with 7.6.x but otherwise you can give 7.8.x a try since it is still part of the same branch.

Re: Elasticsearch version for 2.4

Magento 2.4 adds support for Elasticsearch 6.x, and it is enabled by default. You must install and configure Elasticsearch 7.6.x before upgrading to Magento 2.4.0.

Re: Elasticsearch version for 2.4

Tried with 7.6.2 and it did not work. There is an error in documentation. Minimum requiered version of elasticsearch is 7.7.0

- magento/product-community-edition 2.4.0 requires elasticsearch/elasticsearch ~7.7.0 -> satisfiable by elasticsearch/elasticsearch[7.7.x-dev, v7.7.0] but these conflict with your requirements or minimum-stability.
- magento/product-community-edition 2.4.0 requires elasticsearch/elasticsearch ~7.7.0 -> satisfiable by elasticsearch/elasticsearch[7.7.x-dev, v7.7.0] but these conflict with your requirements or minimum-stability.
- Installation request for magento/product-community-edition 2.4.0 -> satisfiable by magento/product-community-edition[2.4.0].

Re: Elasticsearch version for 2.4

@ivan_golubovic 

 

Sorry for the slow reply!

I have a large customer store that is running Magento 2.4.x and Elasticsearch 7.9.0 with zero issues and no customisations.

Just wanted to confirm it works Smiley Happy

--
Problem solved? Click Accept as Solution!

Re: Elasticsearch version for 2.4

Hi everybody,

 

I'm testing to migrate from Magento 2.2.7 to Magento 2.4.1.

My Develop configuration into Oracle VM (then will be replicated on VPS) is  :

FreeBSD 12.1 (base host + pf Firewall redirect traffic) --> jail proxy (haproxy2.2.4 + ssl) --> jail www (nginx 1.18.0_25 + ssl + php7.4.12 + elasticsearch7.9.1 + modsecurity3-3.0.4_2 + Magento 2.4.1) --> jail db (Mysql Server 8.0.22)

 

This configuration works fine and I was very happy, but when I run "php bin/magento index:reindex" I received from shell the follow error on "Catalog Search index" :

 

.....Catalog Product Rule index has been rebuilt successfully in 00:00:00
Product Price index has been rebuilt successfully in 00:00:00
Catalog Search index  
Fatal error: Uncaught Error: Wrong parameters for Elasticsearch\Common\Exceptions\ServerErrorResponseException([string $message [, long $code [, Throwable $previous
= NULL]]]) in ..../vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connections/Connection.php:665
Stack trace:
#0 ..../vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connections/Connection.php(665): Exception->__construct(NULL, 503)
#1 ..../vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connections/Connection.php(320): Elasticsearch\Connections\Connection->process5xxEr
ror(Array, Array, Array)
#2 .../vendor/react/promise/src/FulfilledPromise.php(28): Elasticsearch\Connections\Connection->Elasticsearch\Connections\{closure}(Array)
#3 ..../vendor/ezimuel/ringphp/src/Future/CompletedFutureValue.php(55): React\Promise\FulfilledPromise->then(Object(Closure), NULL, NULL)
#4 ..../vendor/ezimuel/ringphp/src/Core.php(341): Guzzl in ..../vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connec
tions/Connection.php on line 665


On FreeBSD I cannot downgrade elasticsearch to version 7.6 (as in requirements) and I just tried to susbstitute the directories "lib", "module" and "plugin" on /usr/local/lib/elasticsearch with previuos version but without success.

Any suggestion is appreciated to resolve the problem.
Thank in advance, Matteo

Re: Elasticsearch version for 2.4

You can solve this issue by downgrading from ElasticSearch 7.8.x (latest) to 7.6.2 explicitly.

See this github topic, there's a person who encounter the same issue: https://github.com/magento/magento2/issues/29454