cancel
Showing results for 
Search instead for 
Did you mean: 

Elasticsearch version for 2.4

Highlighted

Elasticsearch version for 2.4

Planning to upgrade to 2.4 and I was wondering will Magento work on Elasticsearch 7.8 or is it better to go to 7.0?

Anyone tested this yet?

4 REPLIES 4
Highlighted

Re: Elasticsearch version for 2.4

Magento 2.4 officially supports Elasticsearch 7.6.x but should work with 7.8.x as well.

 

If you are risk averse, you can go with 7.6.x but otherwise you can give 7.8.x a try since it is still part of the same branch.

Highlighted

Re: Elasticsearch version for 2.4

Magento 2.4 adds support for Elasticsearch 6.x, and it is enabled by default. You must install and configure Elasticsearch 7.6.x before upgrading to Magento 2.4.0.

Highlighted

Re: Elasticsearch version for 2.4

Tried with 7.6.2 and it did not work. There is an error in documentation. Minimum requiered version of elasticsearch is 7.7.0

- magento/product-community-edition 2.4.0 requires elasticsearch/elasticsearch ~7.7.0 -> satisfiable by elasticsearch/elasticsearch[7.7.x-dev, v7.7.0] but these conflict with your requirements or minimum-stability.
- magento/product-community-edition 2.4.0 requires elasticsearch/elasticsearch ~7.7.0 -> satisfiable by elasticsearch/elasticsearch[7.7.x-dev, v7.7.0] but these conflict with your requirements or minimum-stability.
- Installation request for magento/product-community-edition 2.4.0 -> satisfiable by magento/product-community-edition[2.4.0].
Highlighted

Re: Elasticsearch version for 2.4

@ivan_golubovic 

 

Sorry for the slow reply!

I have a large customer store that is running Magento 2.4.x and Elasticsearch 7.9.0 with zero issues and no customisations.

Just wanted to confirm it works Smiley Happy

--
Problem solved? Click Accept as Solution!