cancel
Showing results for 
Search instead for 
Did you mean: 

Credit card png logos not showing, urls doubled in source

SOLVED
Highlighted

Credit card png logos not showing, urls doubled in source

We are working on a website and using snowdog as our base theme.

 

Magento CE 2.3.3

 

The problem that we are having is that when the credit card logos are displayed in the checkout the image source contains the url to the images twice, so this comes up as a missing image. 

 

For example: https://www.example.com/static/version1581283705/frontend/Links/custom/en_US/Magento_Payment/images/...

 

At first we thought it was being caused by the payment module that we were using, but we have changed payment modules and it is still doing it, and now instead of pointing to the module's images, it is pointing to Magento_Payment's images. I have checked and the images are at the url, but not when it is doubled. 

 

Also, in my local dev environment, it isn't doubled. We have had this deployment on several different servers, with the same issue. 

 

The webserver is nginx. 

 

Thank you in advance for any help.

 

Mike

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Credit card png logos not showing, urls doubled in source

Thank you both for your help. I found the problem. In the end it was one of our modules that was causing the issue. When I disabled that module, the issue went away.

 

Again, thank you both for your help.

 

If anyone else should run into this, for us the BluePay_Payment module was causing this issue for us. I am not completely sure if it was conflicting with another module or if it was all this module, but when I disabled it from the CLI, the issue went away.

 

Mike

View solution in original post

8 REPLIES 8
Highlighted

Re: Credit card png logos not showing, urls doubled in source

Hi @mike_toothaker 

 

Might me cache are not generated for the images.

Rn command from magento root path
sudo chmod -R 0777 pub/media

php bin/magento catalog:images:resize

php bin/magento cache:flush

--
If my answer is useful, please Accept as Solution & give Kudos
Anuradha Bissa

Highlighted

Re: Credit card png logos not showing, urls doubled in source

@mike_toothaker Can you please check the payment method configuration and check if there is any setting which is asking for base url.

 

Thanks

Highlighted

Re: Credit card png logos not showing, urls doubled in source

Rahul,

 

Thanks for your reply. I don't see anywhere that it is asking for a base url. We are using the Braintree module, that I believe comes as part of Magento 2, but we had the same problem when we were using the Bluepay module previously.

 

Mike

Highlighted

Re: Credit card png logos not showing, urls doubled in source

@mike_toothaker is there any public url where i can check?

Highlighted

Re: Credit card png logos not showing, urls doubled in source

Anuradha,


Thank you for your reply. This did not seem to do anything. 

 

Thanks,

Mike

Highlighted

Re: Credit card png logos not showing, urls doubled in source

Rahul,

 

Sure, I will send it to you in DM.

 

Thanks,

Mike

 

Highlighted

Re: Credit card png logos not showing, urls doubled in source

Thank you both for your help. I found the problem. In the end it was one of our modules that was causing the issue. When I disabled that module, the issue went away.

 

Again, thank you both for your help.

 

If anyone else should run into this, for us the BluePay_Payment module was causing this issue for us. I am not completely sure if it was conflicting with another module or if it was all this module, but when I disabled it from the CLI, the issue went away.

 

Mike

View solution in original post

Highlighted

Re: Credit card png logos not showing, urls doubled in source

Hi @mike_toothaker,

 

It's my pleasure.
--
If my answer is useful, please Accept as Solution & give Kudos
Anuradha Bissa