Showing results for 
Search instead for 
Did you mean: 

Magento Installs without Theme on server

Magento Installs without Theme on server

Hi folks,


I'm developing Magento on Docker on my Mac. I've applied a theme and made a few customizations. I created a git repo, with a gitignore file according to the documentation. I pushed my code to the repo.


On the other machine I've installed the project:


composer create-project --ignore-platform-reqs --repository= magento/project-community-edition magento
# I'm using --ignore-platform-reqs once all the dependencies are inside the docker container
cd magento/

# Inside the docker container
bin/magento setup:install --base-url=$baseURLInsecure --base-url-secure=$baseURLSecure --backend-frontname=${BACKEND_FRONTNAME} \
                            --language=${DEFAULT_LANGUAGE} --currency=${DEFAULT_CURRENCY} --timezone=${DEFAULT_TIMEZONE} \
                            --db-host=mysql --db-name=${DATABASE_NAME} --db-user=${DATABASE_USER} --db-password=${DATABASE_PASSWORD} \
                            --admin-firstname=${ADMIN_FIRSTNAME} --admin-lastname=${ADMIN_LASTNAME} --admin-email=${ADMIN_EMAIL} --admin-user=${ADMIN_USERNAME} --admin-password=${ADMIN_PASSWORD} \
                            --cleanup-database --session-save=db


And pulled the git repo


git init
git remote add origin git@git...
git pull origin master 
#here I get some errors, git refuses to merge so I force the merge
git fetch --all
git reset --hard origin/master



I tried following these steps stated on other post but it didn't work:

sudo php bin/magento maintenance:enable
sudo rm -Rf pub/static/frontend/* var/pre_processed/* pub/static/_requirejs/*
sudo rm -Rf var/generation/* var/di/* var/cache/*
sudo php bin/magento setup:upgrade
sudo php bin/magento setup:di:compile
sudo php bin/magento setup:static-content:deploy -f
sudo php bin/magento cache:clean
sudo php bin/magento cache:flush
sudo chmod -R 777 var/ pub/ generated/ 
sudo php bin/magento maintenance:disable


Still, the theme and customizations don't load and I see default Luma page. Any ideas?



Re: Magento Installs without Theme on server

Hello @antonioaraujo 


Have you take DB from the server and copy into docker?



Problem solved? Click Kudos & Accept as Solution!
Sunil Patel
Magento 2 Certified Professional Developer & Frontend Developer

Re: Magento Installs without Theme on server

No, I haven't. 
I found an article describing the procedure to make the dump is to execute this line:

mysqldump --single-transaction -u username -p database_name --triggers | sed -e 's/DEFINER[ ]*=[ ]*[^*]*\*/\*/' | gzip > database_name_.`date +"%Y%m%d"`.sql.gz

I will try ASAP.

Re: Magento Installs without Theme on server

I've synced the database from the production environment, and now when I type my local environment address (, I'm redirected to my production site ( 

Maybe I have to sync just one specific table. But which one? 

Re: Magento Installs without Theme on server

Hi, it was really one table that I needed to sync. It is a table related to my theme. 
For future reference, if you have the same problem you may want to use PHPMyAdmin and look on your tables, to see if there's any table that contains data relative to the theme.