cancel
Showing results for 
Search instead for 
Did you mean: 

Can't add subcategory

Highlighted

Can't add subcategory

Hello,

 I can't add any subcategory to the parent one. I fill out all fields, but always receiving this error: 

The "Ratio" attribute value is empty. Set the attribute and try again.

https://prnt.sc/uzpu9f

 

I tried reindex and cc

 

php bin/magento indexer:reset
php bin/magento indexer:reindex
php bin/magento c:c && bin/magento c:f 
php bin/magento setup:upgrade
php bin/magento setup:di:compile 

Unfortunately without any results. 

I also tried to add the category via product page. The same issue occured.

 

Do you have any idea what may be wrong?

Please help me. I will be grateful for any suggestion.

Magento ver. 2.3.5-p2

3 REPLIES 3
Highlighted

Re: Can't add subcategory

Please try this solution:

Go to table "eav_attribute": find line attribute code "is new" and edit:

  1. mark "is required" to: 0

  2. under "default value" text, uncheck the check box and set (write in) the field box: 0

Hope this helps!

Highlighted

Re: Can't add subcategory

Unfortunately I do not have "is new" attribute code in eav_attribute tab.

 

Added: I just checked fresh new Magento 2.3.5-p2 installation and there is no "is_new" attribute code in eav_attribute tab...

Highlighted

Re: Can't add subcategory

Hello @michal_barlinek 

 

Magento default doesn't have attribute like "ratio", it must be from your any extension installed or in custom module.

 

You can find in eav_attribute table as "Ratio", if not directly found, then try to find it by label.

then make change the is_required to 0.

 

PS: make sure you know the reason behind using of that attribute.

 

Hope that helps !

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !