cancel
Showing results for 
Search instead for 
Did you mean: 

JS & CSS not loading After Enable SSL

SOLVED
Highlighted

JS & CSS not loading After Enable SSL

Hi,

 

JS & CSS not loading to my website after I enable the SSL certificate

 

Its working fine with HTTP only but without format in HTTPS

 

I have try most solutions of not loading JS & CSS and not works ! 

Could please help to solve the issue?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: JS & CSS not loading After Enable SSL

Hello @Sumayah,

 

Can you please add a screenshot of the error?

And also try to execute below command and try it in magento root directory 

$ rm -rf pub/static/frontend/* pub/static/adminhtml/* var/cache/ generated/* var/page_cache/ var/view_preprocessed/ var/composer_home 
$ php -dmemory_limit=6G bin/magento setup:static-content:deploy -f

--
If my answer is useful, please Accept as Solution & give Kudos

 

View solution in original post

5 REPLIES 5
Highlighted

Re: JS & CSS not loading After Enable SSL

Hi @Sumayah

 

So what you have tried so far ? as you mention you have tried Most solution so if possible can you share what you have tried ?

 

Have you changed base_secure_url and base_unsecure_url in core_config_data table ?

if issue solved,Click Kudos & Accept as Solution
Highlighted

Re: JS & CSS not loading After Enable SSL

Yes 
I have try these

Highlighted

Re: JS & CSS not loading After Enable SSL

Hello @Sumayah,

 

Can you please add a screenshot of the error?

And also try to execute below command and try it in magento root directory 

$ rm -rf pub/static/frontend/* pub/static/adminhtml/* var/cache/ generated/* var/page_cache/ var/view_preprocessed/ var/composer_home 
$ php -dmemory_limit=6G bin/magento setup:static-content:deploy -f

--
If my answer is useful, please Accept as Solution & give Kudos

 

View solution in original post

Highlighted

Re: JS & CSS not loading After Enable SSL

Thanks its works for after all these steps 

  • Clear caches like rm -rf var/cache/* var/di/* var/generation/* var/page_cache/* var/view_preprocessed/* pub/static/frontend/*
  • php bin/magento setup:upgrade
  • php bin/magento setup:di:compile
  • php bin/magento setup:static-content:deploy ( Deploy Should done for each Site with Locale code) 
  • bin/magento setup:static-content:deploy ar_SA
Highlighted

Re: JS & CSS not loading After Enable SSL

Thanks its works for after all these steps 

  • Clear caches like rm -rf var/cache/* var/di/* var/generation/* var/page_cache/* var/view_preprocessed/* pub/static/frontend/*
  • php bin/magento setup:upgrade
  • php bin/magento setup:di:compile
  • php bin/magento setup:static-content:deploy ( Deploy Should done for each Site with Locale code) 
  • bin/magento setup:static-content:deploy ar_SA