Showing results for 
Search instead for 
Did you mean: 

Magento 2.4.4 undefined constant in reader.php

Magento 2.4.4 undefined constant in reader.php


I am trying to install Magento 2.4.4 on local and faced the below undefined constant error after running

bin/magento setup:upgrade

Composer install did run successfully before running this command.

php version is 8.1.5

composer version is 2.2.4

OS: pop-OS

Magento version: 2.4.4 Enterprise Edition (the Magento instance is fetched from a remote repo)

Elasticsearch is up and running

The error message is

Undefined constant "​"#0 /var/www/html/project-code/vendor/magento/framework/App/DeploymentConfig/Reader.php(113): include()
#1 /var/www/html/project-code/vendor/magento/framework/App/DeploymentConfig.php(171): Magento\Framework\App\DeploymentConfig\Reader->load()
#2 /var/www/html/project-code/vendor/magento/framework/App/DeploymentConfig.php(79): Magento\Framework\App\DeploymentConfig->load()
#3 /var/www/html/project-code/vendor/magento/framework/App/ObjectManagerFactory.php(117): Magento\Framework\App\DeploymentConfig->get()
#4 /var/www/html/project-code/vendor/magento/framework/App/Bootstrap.php(212): Magento\Framework\App\ObjectManagerFactory->create()
#5 /var/www/html/project-code/vendor/magento/framework/App/Bootstrap.php(127): Magento\Framework\App\Bootstrap->__construct()
#6 /var/www/html/project-code/vendor/magento/framework/Console/Cli.php(184): Magento\Framework\App\Bootstrap::create()
#7 /var/www/html/project-code/vendor/magento/framework/Console/Cli.php(84): Magento\Framework\Console\Cli->initObjectManager()
#8 /var/www/html/project-code/bin/magento(22): Magento\Framework\Console\Cli->__construct()
#9 {main}

Also tried this in wamp and it gave same error. 

Thank you in advance!! 




Re: Magento 2.4.4 undefined constant in reader.php

Assetz Soho and Sky offers Best designed and planned gated community in North Bangalore.Floors Plans of Soho and Sky comes with right space management to suite the requirements of the homebuyers.


Re: Magento 2.4.4 undefined constant in reader.php

Did you find a solution? I got same issue with a M2.4.5 on one server running, but not on the other...