cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 CLI Stopped Working

SOLVED

Magento 2 CLI Stopped Working

All of sudden magento 2 cli stopped working..

 

Im getting 

 

iissux@xieos:/data/www/pneumatig$ php bin/magento setup:upgrade
An abstract factory could not create an instance of magentoframeworkappdeploymentconfig(alias: Magento\Framework\App\DeploymentConfig).

how do i fix that?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Magento 2 CLI Stopped Working

I resolved it by upgrading for the second time, now its working, thanks

View solution in original post

6 REPLIES 6

Re: Magento 2 CLI Stopped Working

Hi @patryk_wojciechowski 

 

It looks like this is a generated factory class issue.

 

To resolve this issue, I would suggest you to remove the generated directory by runnig the following command in sequence and then check !

 

rm -rf generated
rm -rf var/cache/*
rm -rf var/view_preprocessed
rm -rf pub/static/*
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
php bin/magento cache:clean
php bin/magento cache:flush

 

Hope it helps !

if issue solved,Click Kudos & Accept as Solution

Re: Magento 2 CLI Stopped Working

I resolved it by upgrading for the second time, now its working, thanks

View solution in original post

Re: Magento 2 CLI Stopped Working

Hi @patryk_wojciechowski

 

I would suggest you to run the following command in sequence:

 

rm -rf generated
rm -rf var/cache/*
chmod -R 777 var pub generated

 

Hope this can help you! Let me know if you need further assistance. 

 

_____________

If issue solved, Click Kudos & Accept as Solution.

Marcus | LitExtension Expert
Shopping Cart Migration Service

Re: Magento 2 CLI Stopped Working

can you please explain more about this


@patryk_wojciechowski wrote:

I resolved it by upgrading for the second time, now its working, thanks


 

Re: Magento 2 CLI Stopped Working

also faced problem with cli stoped working with 

An abstract factory could not create an instance of magentoframeworkappdeploymentconfig(alias: Magento\Framework\App\DeploymentConfig)

so i  delete /vendor folder and run

composer install

 now it works fine

Re: Magento 2 CLI Stopped Working

same error and solution that worked for me...

Actually I updated my ubuntu and upgraded it due which ubuntu automatically install php8.0.1 which was not compatible with my magento version 2.3.6. to move from php8.0.1 to php7.3.26 I used the following command.

sudo update-alternatives --set php /usr/bin/php7.3

after changing the php version my magento cli start working.