cancel
Showing results for 
Search instead for 
Did you mean: 

No product images in product view

SOLVED

Re: No product images in product view

Any suggestions?

Re: No product images in product view

I'm wondering if I need to reinstall Magento. I have some other minor issues with the admin side, such as, when I log in I've designated Pages as the default page to go to. However, when I initially choose, say, Catalog > Products, Magento reverts back to Pages and I have to try again. 

 

Other than that, the issue I've been having with no products but one on the category page and no images on the product page still persist.

 

I'm at a loss.

Re: No product images in product view

Reindexing solved the category page and featured images slider on the homepage, but the product page still hangs with images not loading.

Re: No product images in product view

I continue to have issues with category and product pages. One issue was I had not installed all the theme (Porto) patches because it wasn't clear in the documentation which patches needed to be installed. That initially solved some of the problems. However,

 

I added more products, but only the first three I added are visible. One product is found only in one category (workshops). The other two products are found in multiples categories (classes, foundation and modules). The new products I've added are in classes, foundation, modules, creative, or business), but none of the newly-added products appear on any page, neither their respective category view or product view. 

 

I've cleared all caches, refreshed all caches, re-indexed, and whatever other resets or refreshing I can do. 

 

I've been in contact with Porto support and they suggested I revert back to the Luma theme. I did and there was no change. So, I'm back to my previous question whether I need to reinstall Magento (2.3.5pl), or is there another test I can do?

 

https://www.blueplanetphoto.com/store/  

Re: No product images in product view

After more digging, I discovered this forum post:

https://community.magento.com/t5/Magento-2-x-Technical-Issues/products-not-showing-in-category-on-fr...

I reindexed and cleaned and cleared the cache according to the solution for what appears to have been the exact issue I'm having, and it worked. 

 

Now I'm suspecting the indexing plugin I installed and its effectiveness. I'm going to mark this as solved.

View solution in original post